1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Is anyone having the same problem with the new Driving Force GT drivers (Mar. 2016)?

Discussion in 'Automobilista' started by Óscar Melero, Apr 10, 2016.

  1. Since I've installed the new drivers, because Sector3 recommended it for R3E, the automatic steering rotation and automatic steering lock won't work for:

    Automobilista
    rFactor2

    Steering angle and lock doesn't match with in-game steering and lock.

    And I've made myself sure that I'm running the correct configurations on the Logitech Profiler and the two games.
    (Automobilista is set to Use Custom Rotation Setting: NO)

    Is anyone having the same problems? Please, help...
     
  2. Yes me too. :(

    If I use new drivers for R3E, AMS steering angle and lock doesn't match with in-game steering and lock.

    It's very anoying. :mad:
     
  3. I have the same issues, except the steering lock doesn't even match in RRRE anymore either. I guess the best course of action would be posting on the logitech forums about it? The DFGT logitech gaming software still is dated from 2010 in the infos, same for the driver in the wheel's windows properties. I tried downloading the g29 software, but it won't even recognize the DFGT. Annoying to say the least.
     
  4. For me it works ok on Assetto Corsa and Raceroom Racing Experience.

    Long story short:

    The thing is I have the perfect settings for automatic steering ratio in these games:
    Assetto (900º and no more; adjusts to every car automatically)
    Raceroom (900º and no more; adjusts to every car automatically)
    Automobilista (Custom steering rotation is set to NO; adjusts automatically)
    rFactor 2 (Steering is set to "Vehicle Set" so it can adjust automatically)


    3 days ago I went to drive in Automobilista and I saw my wheel is not recognized.
    I went to Logitech site and of course, new drivers available. I saw that Raceroom recommends installing the new drivers, so I installed them.
    When I installed the new drivers Automobilista went from not detecting the wheel to detecting it but no automatic steering ratio at all.
    It happens the same on rFactor 2. But Assetto and Raceroom are alright.

    What can be wrong? I think it is Automobilista's and rFactor 2's fault.
    Is an update needed, @Renato Simioni ?
     
  5. I use old drivers and had not problem
    I downloaded it when I bought the steering wheel and not updated more (2012)
    using older drivers, do you still have the same problem?
    before playing..., I open the profile and press OK (on rotation, effects ..)
    in game, press the pedals a few times and I map again
    I think the automatic calibration when you plug the steering wheel does not work so well after some time
    then I prefer to do this procedure
     
  6. If it is a problem about the old and new drivers, I think these two games (AMS and rF2) need an urgent update to be compatible to new drivers.
    Let's see what can Renato say about this...
     
  7. no, I have no problems with the AMS (with older drivers)
    the procedure I do since rfactor 1
    just to not have problems with the automatic calibration (when wheel turn left, right after plug in usb)
     
  8. What driver version are you using?
    Download link, please?
     
  9. I'm at work, here I use the notebook
    this driver installed 4.1.100.1332
    at home on my pc, may be older
    I don't know where that link to download
    but I can send you if you want it
     
  10. Morello

    Morello
    Premium Member

    I briefly had this issue with my G25 after installing the "new" drivers as recommended by Raceroom. Mine sorted itself out after I changed it to custom wheel rotation and set it to a number, went into a race, confirmed it was at the correct rotation, then went back to the options and set the custom rotation back to no. From then on it has been OK for me, but it may have been coupled with going into the Logitech Profiler and re-saving my settings.
     
  11. I'll try that out, thanks!
     
  12. Dann Murillo

    Dann Murillo
    Premium Member

    Are you guys running the AMS & the Logitech application as admin? That makes a huge difference in windows 10.
     
  13. Solved in Windows 10 by running LGS and AMS as admin, both.

    This workaround works aswell with rFactor 2, and other games which lost the automatic steering ratio and lock.

    This seems to be a problem only present on Windows 10. I'm starting to think is not AMS or rF2 fault, it's the drivers'
     
    • Like Like x 1
  14. Not only on W10, I have W7 and have same issues. :redface:
     
  15. BattleOvce

    BattleOvce
    Premium Member

    5.10.127 version, working for me, didnt get any updates automaticly since I have installed logitech profiler.
     
  16. If it's W10 and W7, then I guess it must be game's "fault". An update to the games (AMS & rF2) could be needed.
     
  17. Martin Vindis

    Martin Vindis
    Premium Member

    From what I've understood there was some changes in the Logitech API, that's why R3E is warning player to upgrade as R3E uses the new API in 1.5 and above.
    Now I don't know how this mumbojumbo works but it sounds very much like Reiza and ISI might want to have a closer look at this even if it still works fine for me in both AMS and RF2 on my G27 under Windows 10.
    While you're at it you might want to take look at G29 support as well as I know people that had issues from the start with G29.