• Racing is not a matter of life and death. It's much more important than that!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you have any questions, please don't hesitate to ask. There's no such thing as a stupid question.

Insane stutter @ Portimao

Discussion in 'RaceRoom Racing Experience' started by Kjell Eilertsen, Jul 4, 2014.

  1. Kjell Eilertsen

    Kjell Eilertsen

    Messages:
    3,760
    Ratings:
    +1,244
    I encountered some insane stutter when trying Portimao for the first time today, it's unplayable a good amount of the time. First lap usually is rather stutter free, sometimes not, but from lap 2 and on I get massive stutters.
    My FPS is jumping between 80 to 120 and occasionally will dip down to 59 (lowest I've seen it), but I can have these stutters even at 100+ FPS. I've checked CPU and RAM usage when this happens and nothing suspicious there.
    I've tried:
    Several cars, same issue.
    Other trakcs, no issues.
    Rebooting my system, no difference.

    I've attached my dxdiag to this post but here's a quick rundown on my specs:
    Win 8.1 Pro 64bit
    i5 2500k stock clock
    8GB 1333mhz RAM
    Geforce GTX780 ASUS OC (I haven't OC'ed further)

    Any ideas? Anyone mind testing their Portimao and see if it's acting normally?
     

    Attached Files:

  2. Blkout

    Blkout

    Messages:
    2,668
    Ratings:
    +559
    This track has performance issues.
     
  3. yusupov

    yusupov

    Messages:
    906
    Ratings:
    +139
    indeed it does, i posted about it on the steam board, havent had a chance to check back yet. thought id finally found optimal settings for my PC & this thing killed that. maybe it was microstutters as my fps were in the 50s but seemed like they were in the 20s or lower. so yeah, good to know its not just me.
     
  4. Kjell Eilertsen

    Kjell Eilertsen

    Messages:
    3,760
    Ratings:
    +1,244
    Thats a bummer, awesome track and so much fun in the Audi 90, until the stutter kills it ><
     
  5. James Cook

    James Cook
    Marcas fan

    Messages:
    1,017
    Ratings:
    +345
    Great track. Hope it gets optimised.
     
    • Like Like x 1
    • Agree Agree x 1
  6. yusupov

    yusupov

    Messages:
    906
    Ratings:
    +139
    sooo, update. this is now fine for me. didnt do a framecheck but the stuttering etcs gone & if it wasnt the same fps as other tracks, its not gonna be an issue if yr getting 59+ fps on a 60hz monitor.

    thing is...all the changes ive made to my settings save one (that i recall) have been enabling & dialing up a couple things after seeing a guys setup on steam for a 6890 (i think).

    i turned FXAA off. idk if that did it or its just a temporary fluke that im getting good performance or if yesterday was the fluke or what. but yeah, there ya go.
     
  7. Kjell Eilertsen

    Kjell Eilertsen

    Messages:
    3,760
    Ratings:
    +1,244
    You run without anti aliasing?
     
  8. yusupov

    yusupov

    Messages:
    906
    Ratings:
    +139
    no..actual AA i actually turned up, run at 8x now.

    have you tried the track/did flipping off fxaa change anything for you?
     
  9. Kjell Eilertsen

    Kjell Eilertsen

    Messages:
    3,760
    Ratings:
    +1,244
    No haven't tried that yet, just woke up and have kids to take care of :p
    I will test that later today though.
    To be perfectly honest I have lost track of all the anti aliasing options these days, the double triple QFXXFASF Settings vs the single XXAGFUY x16? It's all gibberish to me :p
     
    • Agree Agree x 2
  10. yusupov

    yusupov

    Messages:
    906
    Ratings:
    +139
    ;D yeah no worries; seems most every race sim has two kinds, FXAA, which is software based & has (almost? always) pretty much no impact on performance, but blurs the picture to get rid of jagged lines. MSAA is much more complex, 'real' hardware AA; thats the one that in R3E you can turn from 2X-8X. usually a big performance hitter but doesnt seem to be as much of one in these gmotor games.
     
  11. Peter

    Peter
    who cares Premium

    Messages:
    1,723
    Ratings:
    +667
    I tested Portmao for an hour with different car, but I don't and never had any problem there.

    i5-2500k / gtx 660ti
     
  12. yusupov

    yusupov

    Messages:
    906
    Ratings:
    +139
    weird...maybe it was just bugging out yesterday?? we're all nvidia so i really dont get it.
     
  13. Kjell Eilertsen

    Kjell Eilertsen

    Messages:
    3,760
    Ratings:
    +1,244
    I'm still having stutter, and as I mentioned in this thread; http://www.racedepartment.com/threads/recommendations.89691/#post-1763869
    I've tried lowering some settings and have less stutter now but it's still present.
    @William Wester and @Peter Koch do you guys run the game off a SSD?
    Don't think that should make a difference as it should be done loading once I'm on track, but I don't understand what's going on here.
    Also, are you running with ShadowPlay activated (but not recording/streaming)? I'll try disable that now to see if it makes any difference.
    @Peter Koch are you running lower settings than those in Williams post at the thread I linked?
     
  14. Kjell Eilertsen

    Kjell Eilertsen

    Messages:
    3,760
    Ratings:
    +1,244
    Just tested with ShadowPlay disabled, no difference.
    I'm on Nvidia Driver version 337.88, if you wouldn't mind checking yours?
     
  15. William Wester

    William Wester
    Premium

    Messages:
    1,061
    Ratings:
    +337
    No ShadowPlay here either, I've never tried as it doesn't work with triple screen surround. As for my NVidia driver, I am also running 337.88.
    I have my system (Windows 8.1 Pro x64) on my SSD but most everything else I have installed to a 7.2K HDD SATA drive. You've seen my settings in that other thread, and I assume you have VSync enabled. With your computer specs. you shouldn't have any problems getting a decent FPS. I can't think of any suggestions at this point but maybe focus on background processes (Antivirus, Splashtop, iSpeed, etc.).
     
  16. Tony Hope

    Tony Hope

    Messages:
    28
    Ratings:
    +10
    You could also try going to Nvidia control panel, manage 3D settings in the drop down list see if R3E is there it probably is not and add it. then set pre-rendered frames to 2 ,in the multi diplay section set it to single display performance mode,in power management set it to prefer max. performance.
    Make sure you are running PCIe gen 3, with that M/B it should be. use GPU-z to check
    Select performance mode in windows power management in control panel
    You can also try this http://bitsum.com/about_cpu_core_parking.php this helped with stuttering in BF4
    I run Win 7 with a I7-3820
    GTX 780Ti black
    I just tested the circuit for an hour or more with no stuttering at 70-90 Fps on high pre-set
    I run all the above things
     
  17. Kjell Eilertsen

    Kjell Eilertsen

    Messages:
    3,760
    Ratings:
    +1,244
    Thanks I'll try those as well as disabling antivirus. I do not have vsync on, it was in fact the first thing I turned off try remedy the problem.
     
  18. Peter

    Peter
    who cares Premium

    Messages:
    1,723
    Ratings:
    +667
    My settings
    http://www.racedepartment.com/threads/hw-requirements-cpu-intensive.80150/#post-1610429

    Windows 8.1 x64 without additional anti virus.

    I have a SSD, no shadowplay and use the latest nVidia beta driver. Min. Fps 75 - max 110.
     
  19. Kjell Eilertsen

    Kjell Eilertsen

    Messages:
    3,760
    Ratings:
    +1,244
    Thanks Peter, I see you have quite a few additional effects turned off, that might make a difference, I'll test your settings as well but seeing how others running the same card as me (780) are able to run the same settings as I have now without stutter, I hope that there's some other explanation to my issues.
     
  20. Peter

    Peter
    who cares Premium

    Messages:
    1,723
    Ratings:
    +667
    My main interest is physics/FFB and with those bloom/lens effects turned of it still looks very good racing in cockpit view.