• "Bwoah." - Generic Kimi Quotes.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you have any questions, please don't hesitate to ask. There's no such thing as a stupid question.

How to get rid of deadzone in Steering?

Discussion in 'Project CARS' started by Burke Wells, May 7, 2015.

  1. Burke Wells

    Burke Wells

    Messages:
    152
    Ratings:
    +107
    Even with the steering deadzone slider at 0, I still have a huge deadzone when turning the wheel. I'm literally having to turn my Thrustmaster wheel to almost 45 degrees before the on-screen wheel starts to turn. It's very frustrating and basically making it undriveable at the moment.

    Was hopeful of finding an editable cfg or ini file among the PC folder files but saw none as of yet.

    My wheel/pedals combo is the Thrustmaster VG Ferrari 458 (no FFB). Works flawlessly in AC, GSCE, Dirt Rally, and others. This is my first time to see this deadzone issue.

    Any advice is appreciated. Really hoping to get this fixed soon.

    Burke
     
  2. Skazz

    Skazz

    Messages:
    397
    Ratings:
    +101
    I've been playing pCARS beta for more than a year on Thrustmaster gear (T500 and T300) and never experienced this....

    Have you calibrated the wheel in game?
     
  3. yusupov

    yusupov

    Messages:
    908
    Ratings:
    +139
    yes--deadzone removal is in the game, not sure why a thrustmaster would have an issue, but yeah. like everything in pCARS its confusing, you have to go to wheel calibration to get to that part of the ffb setting, there you can remove the deadzone.

    yeah, they divided the ffb into 3 different sections, in 3 completely different parts of the game...
     
  4. yusupov

    yusupov

    Messages:
    908
    Ratings:
    +139
    oh, sorry, i just saw 'deadzone' & stopped. the onscreen wheel not even turning is bizarre...im guessing there will be a patch out any time for that??
     
  5. yusupov

    yusupov

    Messages:
    908
    Ratings:
    +139
    ive guessed a solution :)

    bc its thrustmaster maybe the game thinks you have 1080 deg rotation, if you calibrate the degrees of rotation see if that fixes the issue
     
  6. Burke Wells

    Burke Wells

    Messages:
    152
    Ratings:
    +107
    (I should clarify that when I mentioned "having to turn my wheel to almost 45 degrees before the on-screen wheel starts to turn", I'm referring to being in the car driving, looking at the car's steering wheel, not looking at the white wheel in the calibration screen. My apologies for any misunderstanding.)

    Yes, I did try a few attempts of calibrating. While doing so, I discovered that I could set my degrees of rotation to different settings. But regardless of how many degrees I chose, once I'm back in the car driving, the big deadzone remains.

    Interestingly enough, I just saw another user (turnburgler) having the same issue, and he mentioned eliminating the deadzone by using his wheel with the Xbox controller preset. But apparently that still leaves him with other issues regarding oversensitivity, etc. But I haven't tried that yet.

    When I didn't see my wheel represented among the presets, I just chose the "Custom Wheel" option, then calibrated, and saved. Maybe I need to try some of those other presets, especially having now read that someone else eliminated the deadzone with the Xbox controller preset. Will try that next.

    Thanks for the replies, guys. Keep 'em coming if you think of anything else.

    Burke
     
  7. William Wester

    William Wester
    Premium

    Messages:
    1,095
    Ratings:
    +359
    I've never had a problem with my Thrustmaster TX, the wheel animation matches my TX movements exactly. What do you have the rotation set at in the TM control panel? I would also set the pCARS calibration degrees to the same.