• "Mwoah" - Kimi Räikkönen
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

How do I turn off shadows completely

Discussion in 'Assetto Corsa' started by Nibiru Cataclysm, Aug 21, 2017.

  1. Nibiru Cataclysm

    Nibiru Cataclysm

    Messages:
    71
    Ratings:
    +21
    They are giving me eye strain - I have read other threads but the information seems outdated.

    Could anyone please show me how to turn them all off?

    Also is there a way to disable grass rendering?

    Thanks
     
  2. Nibiru Cataclysm

    Nibiru Cataclysm

    Messages:
    71
    Ratings:
    +21
    36 views.... no one has any idea?
     
  3. Michael Hornbuckle

    Michael Hornbuckle

    Messages:
    2,698
    Ratings:
    +2,422
    Use overcast weather?
     
  4. Nibiru Cataclysm

    Nibiru Cataclysm

    Messages:
    71
    Ratings:
    +21
    I do - but what if I want to race in brighter weather?
     
  5. Stereo

    Stereo

    Messages:
    2,434
    Ratings:
    +1,471
    Setting world details lower will remove grass (iirc 80% goes away from max to 2nd highest, 15% more at another step, then all of it 3 steps down)

    All you can do on shadows is lower the resolution, that makes them less pixely.
     
  6. Nibiru Cataclysm

    Nibiru Cataclysm

    Messages:
    71
    Ratings:
    +21
    Thanks Stereo - that's strange though and must have changed in a recent build.

    It used to be the case that you could turn off all shadows by playing about with the .ini files.
     
  7. Richard8746

    Richard8746

    Messages:
    19
    Ratings:
    +1
    The Content Manager program has a setting to disable shadows. Unfortunately it gives a "circle of darkness" effect which moves with the car. Not really usable.
    Settings/Assetto Corsa/Video/Shadow resolution/OFF


    I also find the flickering shadows very annoying. I was using cloudy conditions, but I've found a solution - Sparse Grid Supersampling (NVidia GPU).

    Assetto Corsa
    Options/Display/Anti-Aliasing Samples = 4x
    Shadow Resolution = High (You can change this)

    NVidia Profile Inspector
    [​IMG]


    The settings for Anti-Aliasing Samples and Sparse Grid Supersampling must match e.g. 2x 2x or 4x 4x. I find that 4x 4x looks better on my 1440p monitor

    Antialising - Mode must be Enhance the application setting not override.

    Sparse Grid Supersampling using a lot of GPU power. I'm using a GTX 970, so I need to turn down some of the AC's other settings to get good FPS, but I'd much rather have good tree shadows.

    http://www.guru3d.com/files-get/nvidia-profile-inspector-download,1.html

    ***** EDIT *****
    Sparse Grid Supersampling can be lower than Anti-Aliasing Samples.
    See post #14.
     
    Last edited: Oct 23, 2017
  8. Nibiru Cataclysm

    Nibiru Cataclysm

    Messages:
    71
    Ratings:
    +21
    Hi Richard thanks very much for taking the time to post this - I'll look into this tomorrow morning and let you know how it works out for me!
     
  9. Stereo

    Stereo

    Messages:
    2,434
    Ratings:
    +1,471
    I'm only talking about official stuff, there's always been an unofficial workaround that sets the shadow properties way outside of normal user preferences so that they're never visible while driving. iirc you set the distance between objects before shadows start casting very high. It doesn't turn off shadow rendering though and probably leads to random artifacts when the track happens to have objects in the right place.
     
  10. Nibiru Cataclysm

    Nibiru Cataclysm

    Messages:
    71
    Ratings:
    +21
    O yes these were unofficial hacks in the .ini files.

    To the very point you mention - there was even one that did indeed turn off the rendering completely because even "apparently disabling them" still meant they were rendered and hence used up CPU. But I've tried those same hacks now and they don't work any more.

    I've tried Richard's settings and they work like a dream....but I get very bad frame rates (my CPU isnt the greatest) so I'll just play when the sun is not shining :)
     
  11. Richard8746

    Richard8746

    Messages:
    19
    Ratings:
    +1
  12. Carl Williamson

    Carl Williamson

    Messages:
    114
    Ratings:
    +3
    Go to Program Files(x86)/Steam/Steamapps/Common/Assettocorsa/system/cfg and open up the graphics.ini then change the three SHADOW_MAP_BIAS settings to be 1.000000 and save.

    Voila no shadows
     
  13. RasmusP

    RasmusP
    AC Stuff and G27 help Staff Premium

    Messages:
    2,088
    Ratings:
    +780
    Tried that, doesn't work since a few patches now ;)
    There is a thread about it at the official forums where I read that some weeks ago.
    It's a shame and I now use the shadow-patcher instead. Not pretty but for serious racing I don't need shadows :)
    And it's only a double click so for reply watching etc I re-enable them quickly!
     
  14. Richard8746

    Richard8746

    Messages:
    19
    Ratings:
    +1
    Sorry - After further reading, I've found that this part of my post is incorrect.
    It should be - Sparse Grid Supersampling must match or be lower than Anti-Aliasing Samples.

    I am now using:
    Anti-Aliasing Samples 4x
    Sparse Grid Supersampling 2x.
    This is not quite as good at curing flickering tree shadows, but the FPS hit is a lot less.
     
    Last edited: Oct 23, 2017
  15. Zuffenhausen Weiss

    Zuffenhausen Weiss

    Messages:
    56
    Ratings:
    +6
    Is this a bit of a coincidence that this was posted last week, there's also a poll of what is the perfect sim