• Little Aussie Racing Cars: For when three-wide around a hairpin isn't quite close enough.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you have any questions, please don't hesitate to ask. There's no such thing as a stupid question.

Horrible framerate after crash in WTCC 07, Porto

Discussion in 'RACE 07 - Official WTCC Game' started by Vaughn Stegeman, Apr 18, 2013.

  1. Vaughn Stegeman

    Vaughn Stegeman

    Messages:
    563
    Ratings:
    +190
    Hey all
    I'm actually playing the game-theme solo championship of Race 07, the WTCC '07. I'm driving an Alfa Romeo.
    I'm at race #6, Porto in Portugal. It's a tight street track. Hard to not hit some wall somewhere.
    The thing is, anytime I hit a wall with enough momentum to do damage, be it head-on, backwards, or even sideways, the game suddenly drops to a HORRIBLE slide-show framerate. And I'm talking like 10 fps or worse here. There's been a couple times where I was able to keep driving, and the framerate slowly improved, but never back to the smooth normal framerate.
    I'm driving with a full grid, full damage, graphics settings on high except shadow detail at medium.
    Porto is the ONLY track so far that I've experienced this on.
    My system is:
    Win 7 Pro
    Pentium D dual 3.4 Ghz
    3 gigs RAM
    Nvidia GTX560 Ti w/1Gig VRAM
    80gig SATA HD
    On Motherboard audio.

    I have done some tinkering in my .plr file, but nothing I can see that should be affecting framerates as such. I also have a bunch of mods (cars, tracks) installed. I DO have SimManager installed, so I suppose I could go thru and un-install ALL my mods, then check and see if the problem persists .. but <sigh> what a tedious PITA that would be.

    Basically, I'm hoping someone out there is familiar with this problem and might be able to direct me to the quickest way to fix this. .. Clearly, not crashing is probably my best bet. However, that's rather unlikely over the course of the two races. LOL :p

    Thanks in advance!!
     
  2. Leon Charmant

    Leon Charmant

    Messages:
    641
    Ratings:
    +284
    You could try decreasing the draw distance and the number of cars visible at any given time. And turn off V-Sync (can't remember if R07 has any). All I can think of, but I'm not sure if it'll help anything.
     
  3. Rupe Wilson

    Rupe Wilson
    Senior HistorX club driver Staff Premium

    Messages:
    12,492
    Ratings:
    +5,636
    how often do you clean your PC, is the graphics card or other components covered in dust. check your temperatures
     
  4. Vaughn Stegeman

    Vaughn Stegeman

    Messages:
    563
    Ratings:
    +190
    I've done further testing, and solved the problem for now.
    My temps are fine and my computer isn't dusty. Reducing draw distance did nothing, and the gfx card is controlling v-sync.
    I tested the same course in solo practice mode with the same car - Alfa 156 from WTCC '07. .. The horrible framerate after crashing (regardless where I crashed) continued. .. I tried the same thing with other cars. No framerate drop after crashes. .. now THIS is a curious thing, ain't it?
    I had NO IDEA what was going on here, so I moved to my next step: I replaced my modified .plr file with the original .plr file (which I had, of course, wisely backed up before modifying it).
    LO! All problems disappeared.
    Now, I really don't know what in my modified .plr would cause this single car (the Alfa 156, WTCC '07) to be the only vehicle to cause such horrible framerate drop, and only at this track (Porto '07)
    This is very very very strange to me.

    Anyone got any ideas?
    If anyone is interested in taking a look, here is my modified .plr file :: http://pastebin.com/CDzm3knz
     
  5. Chronus

    Chronus

    Messages:
    1,045
    Ratings:
    +339
    --
     
  6. Vaughn Stegeman

    Vaughn Stegeman

    Messages:
    563
    Ratings:
    +190
    Well, everything is working fine now that I went back to the original .plr file .. and then made some alterations to it again. I'm guessing that it was increased particle and/or smoke detail that was causing the framerate drop. Gotta be careful hand-editing the .plr file.