1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Help with transparency (sketchup to BTB)

Discussion in 'Bob's Track Builder' started by Pedrosilvaaa, Dec 25, 2013.

  1. Hi again,

    I'm trying to create some flowers for my track but I have a little problem. Texture looks fine (transparent background) in sketchup but when i load on btb it just shows black where the transparency should be: [​IMG]

    Must be some simple thing I'm missing but I no pro so please give me some tips. Here's how I'm doing it. Create PNG image with transparent background first then create object in sketchup and save as 3ds. So far everything looks as it should. Then I change the exported sketchup PNG image to DDS with mipmaps (box-filter) and dxt1 (with and without alpha channel none worked) using TheCompressonator. Load Xpacker, import 3ds and change PNG texture with the new DDS. Load BTB and place a flower just to see the background is black :(
     
  2. Hi, I don't know much about Sketchup, but there's some BTB texture tutorial on Youtube, such as http://ppt.cc/HEgA . However, the author of the video uses photoshop instead of Sketchup.
     
  3. The problem is, you have to save the DDS file in DXT3 or DXT5, DXT1 is always completely opaque, no matter what you do. DXT3 has only opaque and transparent (Black/White like), DXT5 also has steps between both (semi transparent, like a greyscale image).
    also you have to check the transparency in the materials tab of the XPacker.
    for your flowers i would recomend DXT3 + Chroma setting, as there are no semi-transparent parts there.

    Greetings,
    Neteye
     
    • Like Like x 1
  4. Alright neteye that did the trick. DXT3 + transparency in xpacker solved that.Thank you very much. Unfortunately there is still something bugging me. Once I load RBR it seems the damn flower is too dark but on BTB it looks good:

    [​IMG]

    I did not tick any shadow options on xpacker nor BTB (not that it would work with RBR anyway). Any idea what it might be this time? :p
     
  5. as i dont have rbr, i dont know... maybe try to set the normals to point always up in the xpacker, objects, normals tab? in race07 on trees this works well if i remember right...
    or a different try would be the specular and emissive colors materials tab, they also work wonders sometimes. here a small example, only the colors and the power changed, looks very different, way more detailed.

    specemissive.jpg

    greetings,
    Neteye
     
  6. 'Render Normals Up' is one of the settings in the Materials tab in Pro (rFactor/RBR) edition if thats any help...
     
    • Beer Beer x 1
  7. Great! It seems to be working now. "Render Normals Up" was the fix. Thanks for you help guys. Have a Merry Xmas!! ;)
     
    • Like Like x 1