1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

HELP: unplayable frame drops, at a loss of how to fix

Discussion in 'Automobilista' started by tylargh, Jun 29, 2016.

  1. tylargh

    tylargh
    twitch.tv/tylargh Premium Member

    I know this is a common problem, I read articles, tried the solutions, used the search, etc.

    Here's an example of the problem:



    SPECS:
    980ti
    i5 5670k
    T300RS
    Windows 10
    Automobilista v0.9.6r

    As mentioned above, I've tried the suggested solutions, including updating the "FB Skip Updates" parameter in controller.ini to higher values but nothing seems to work. Even with FFB effects off, it still stutters. In fact, the game will just reset the value I set back to 3....

    I'm pretty bummed out about this, I really want to play this game. Any tips whatsoever? Thank you

    EDIT: Fixed! The culprit was due to a sketchy windows install, likely bad drivers and registry issues. A fresh install of Windows 10 Home edition and everything is faster and more consistent than ever.

    If you find yourself getting the same issues as me, and have gone through a number of upgrades since Windows 8, consider a fresh install of Windows 10. Honestly best performance increase per dollar I've ever given my PC.
     
    Last edited: Jul 2, 2016
  2. Warren Schembri

    Warren Schembri
    Premium Member

    Turning Shadows down to medium is a good start.
    Special Effects can probably also be turned down a bit
     
  3. Sniper

    Sniper
    Premium Member

    I assume you have unticked windowed mode in launch configuration tool and have shadow blur turned off?
    What are your framerates ctrl+f. ?
     
  4. alexSchmurtz

    alexSchmurtz
    Premium Member

    Check the user guide, it gives really good advices on graphics settings. You can open it when you launch the game from Steam.
     
  5. William Wester

    William Wester
    Premium Member

    I assume it's not a RAM issue, anything over 4GB should be good.
    Also, you don't mention one of the most critical pieces of the puzzle, what resolution are you running - single, triple screens? (HD, 2K, 4K)? All cars/tracks?

    My specs:
    GTX 980, i7, 16GB, Win10, Thrustmaster TX, UltraWide 3440x1440

    AMS Config:
    3440 x 1440
    60Hz
    SweetFX Shaders enabled

    Nvidia Inspector:
    Pre-rendered frames: 1
    Vertical Sync: On with Tear Control: Adaptive
    AA Mode: Override application
    AA Setting: 4x Multisampling
    AA Transparency Multi: Disabled
    AA Tranparency SuperSampling: 4X Sparse Grid Supersampling
    Toggle FXAA: Off
    Texture Filtering Quality: High perf
    Texture Filtering Triliner: Off
    Multi-display: Single display perf. mode
    Power Management: Max perf.

    AMS Display:
    Circuit Objects: Full
    Circuit Textures: Full
    Player Detail: Full
    Opponent Detail: Full
    Texture Filter: X8 Anisotropic
    Special Effects: Full
    Shadows: Max
    Shadow Blur: Off
    Visible vehicles: 32
    Mirrors: On
    FPS limit: 63

    Works for me, everything very smooth...
     
    Last edited: Jun 29, 2016
  6. With a 980 Ti, it isn't going to be shadows or in game graphics settings. I run the same card at 2560 x 1440 @144hz and everything is silky smooth, so there is something else causing this.

    I had some graphics intensive tracks freeze for a moment or two and then keep going, but not continued low frame rate like your video shows. My problem was traced to a low fan setting which was causing the card to get too hot at high load.

    Do you use Nvidia Inspector ?
     
  7. tylargh

    tylargh
    twitch.tv/tylargh Premium Member

    Thanks for some of your replies, I'll be sure to hit them this evening.

    Additionally, I'm using Fanatec CSR Elite pedals, if that changes things.

    I am using windowed mode. I can try fullscreen mode when I get home. The video I posted is a monitor capture, and even though it's scaled down to 30fps, the in game fps is anywhere between 2-60. Seemingly wanting to be around 10.

    16GB DDR3 RAM
    3x 1080p monitors
    I'm assuming all cars, this test was done with the rental cart at a kart track.

    I don't, how do I access that?
     
  8. I get micro stutters and fps drops everytime there's an update. All I do now is delete all files and re-install. Everything smooth again after.

    i7, gtx 970, 8gb, W10, 1920x1080 tv, T300rs wheel, G27 pedals
     
  9. tylargh

    tylargh
    twitch.tv/tylargh Premium Member

    Which files do you delete? Install + documents?
     
  10. That seems pretty extreme. There must be a better option.
    Nvidia Inspector just allows you to tweak your game video settings beyond the default control panel. You don't need it.

    Have you tried disabling dynaHUD altogether? It has been troublesome to say the least. It might be causing some kind of issue.
     
    • Agree Agree x 1
  11. tylargh

    tylargh
    twitch.tv/tylargh Premium Member

    I just updated my wheel drivers and those seem to help... a bit. I'm no longer getting 10 fps, now now I'm getting 90fps, but it will instantly drop down to 1-10 if there is a major FFB event, like a crash or a sharp turn....

    It's worth it to note, that the FFB Skip Update is set to 3, and when I try to raise it, it just brings it back down to 3.
     
  12. Every file, you start from scratch. But of course, I have back ups. This is suppose to be the last step but why everytime after the update? So I skip everything and just go for a clean re-install.
     
  13. Gringo

    Gringo
    Premium Member

    Do you have alternate USB ports on your computer you can try... its possible the USB port your wheel is plugged into is not working correctly. Try another USB port... try removing any other USB devices for testing.
     
  14. I think thats your problem right there... if I was you I'd start by reading the configuration manual... worked a treat for me.... I have everything maxed out (in game) and Im on a laptop with a GTX670MX and with no stutters.
     
    • Agree Agree x 1
  15. tylargh

    tylargh
    twitch.tv/tylargh Premium Member

    I neglected to mention that when I reinstalled I went page for page through the manual doing to the suggested optimization. It helped, but not to a degree that I would call the game "playable"

    As far as the USB ports, that's a stretch, my wheel and pedals are recognized fine in both the Windows Device manager, and the Game.

    I'm going to reinstall windows on friday (been meaning to do this for a while, had a weird upgrade from 8.1), and I'm hoping that the clean install might solve what might be a poorly installed system driver or registry setting or something. It's a stretch, but I'll report back when it's done.

    I'd like to thank you all for your help thusfar, truthfully, it did help, I just want to get the game to a level of playability that I think it should be at given my system specs.

    I'm also very hopeful that the devs will address this issue. I'm 100% sure this is FFB related, I've seen it reported multiple times that the FFB in AMS is sent at a very high resolution that differs from other sims, and some wheels just do not respond well to it and it causes FPS issues. I hope the devs can come to a workaround that provides a more bullet-proof "install and play" experience for users. Given this is early-access, I've been very hesitant about dismissing this game, also from what I've played it really does look and feel like a highly-polished sim with great, different content.

    Will keep posting back, thanks again!
     
    • Like Like x 1
  16. Unplug your wheel and run the game. Let the AI do some laps.
     
    • Agree Agree x 1
  17. Renato Simioni

    Renato Simioni
    Reiza Studios

    Tyler, have you tried setting your FFB level to Pure 180hz? I´m assuming it isn´t since you say the tick rates are being automatically reset, and this does sound as you say like a FFB-related performance issue.
     
  18. tylargh

    tylargh
    twitch.tv/tylargh Premium Member

    Thanks for taking the time to respond to me!

    As mentioned earlier, I reinstalled windows last night. It's pretty extreme to do this in order to fix a curious FFB issue with a game, but as I mentioned, my PC was in need of it anyways...

    Well, everything is all good now :)

    I suspect that when I upgraded from 8.1 pro to 10 some bad drivers/registry entries were left behind. Regardless, I would consider my issues an "edge case". Very likely if someone is in the same situation as I was, Automobilista will not be the only application not working properly.

    Loving the game so far, excellent work, especially with the karts! Happy to be able to finally use the sim!
     
    • Like Like x 5
  19. You said you have elite pedals, I've done all mentioned suggestions, gone through manual, graphics settings etc etc. I wonder, as I have huge fps drop rates then as you mentioned about the pedals I recall as soon as I press the brake pedal for the first corner I immediately get a ctd. And I can repeat this, over and over.
     
  20. tylargh

    tylargh
    twitch.tv/tylargh Premium Member

    Try completely removing the fanatec drivers and reinstalling the latest one found here

    https://www.fanatec.com/us-en/support/product;old_product_id;141

    For instance, I have the "Fanatec Driver 64bit v205" installed, and though I don't have a fanatec wheel, the installer appropriately found my pedals and installed them from there.

    Other than that, you may need a new load cell, but I doubt that if your pedals work in other games or in the control panel software.