1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Help running GSCE - error: No DirectX 9.0c video adapters found.

Discussion in 'Stock Car Extreme' started by JoelGL, Sep 29, 2014.

  1. GSCE has been working fine when I was using my older GPU (i.e. NVidia 650Ti Boost SC). But after upgrading to a GTX970 and latest 344.11 drivers, I get the message when running GSCE. I tried GSC Sync, but it just shows TrackConf.txt. Also tried deleting Config.ini, and running GSCE, but the same error.
     
  2. Fabio Rodrigues

    Fabio Rodrigues
    Reiza Studios Community Manager

    I've read that the issue could be a bug with Geforce Experience - the solution is to uninstall Experience (not the whole drivers!) and wait for a new release.
     
  3. Patrick Giranthon

    Patrick Giranthon
    Premium Member

    Perhaps the game has stored your old parameters somewhere. Perhaps a desinstall/reinstall would be ok.
     
  4. When I installed 344.11 (I now have 344.16), I didn't include Geforce Experience. Could be something else?

    @Patrick Giranthon, yes I thought of that, but I'm still thinking of others as I have a lot of mods in that setup. Tried with my other setup (stock) and it opened the config setup again, but then started GSCE in 4:3, weird. It's like it doesn't see my setup properly. Or maybe because my 3D settings were reset? Will try set up 3D again (and inspector).
     
  5. Patrick Giranthon

    Patrick Giranthon
    Premium Member

    Changing CPU or GPU can cause strange thing. So it is a possible cause of your problem. Try with a fresh install. If you have game files stored somewhere it takes 10 min ;-)
     
  6. Check the display tab in dxdiag (Start > Run > dxdiag).
    If there are no devices listed under d3ddisplay and 3d etc, then it could be a faulty driver install. You can try uninstall and reinstall or running the installer again making sure to tick the "clean-install".
     
  7. Patrick Giranthon

    Patrick Giranthon
    Premium Member

    I think about something. Just install dx9 once again. Take it on the Microsoft website
     
  8. Thanks everyone. I think it was the nvd3dum.dll that was causing it. Removed it, and did a re-install of v1.21 files, and it seems to have fixed it. I'm glad I didn't have to go through reinstalling the mods :D

    Appreciate the suggestions. Cheers!

    @poet, BTW, I didn't see any 'd3ddisplay' or '3d' under my Display tabs.