1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Help plz!..Generic pc can't find..what is that?

Discussion in 'Richard Burns Rally' started by Matt555, Jun 11, 2012.

  1. Guys!...When i install my rbr from the original cd is working perfectly.
    But after when i install the RSRBR 2012 mod and i click the rbr icon the game not responding just the blue circle loading and nothing happening.Also when i restart my computer and click the rbr icon,the intro is starting but the game menu not,it show black screen with direct x9 and says.... can't find generic pc....???....also says not enough memory....wtf?...never happened before,2 days ago everything worked just fine,the mod the game everything!Why is that strange problem?
    Thanks any advice people! Help plzz!!!!
     
  2. Warren Dawes

    Warren Dawes
    Premium Member

    If it was working ok before installing RSRBR2012, and now you can't even launch using the default RBR icon, it sounds like a corrupted download or install of RSRBR.

    I'd try re-downloading and re-installing RSRBR.

    One thing to check though, did you install all of the RSRBR2012 Updates, there are 4 of them?
     
  3. Warren Dawes

    Warren Dawes
    Premium Member

  4. I have all 4 updates,and worked fine before!!! And also i didn't touch my RSRBR mod.
    Just uninstalled everything cause i had a sound problem.After installed again and since nothing.
    I tried everything what you wrote Warren,but still nothing.
     
  5. Write the exact error messages you get.
    Google doesn't have a clue about "can't find generic PC"
     
  6. Ok message is this. Could not find GENERIC/PC_Generic_xxx.bnk
     
  7. Well, that helps. That's definitely an issue with the game install. Thought it was some DirectX error or something.

    You've already tried uninstalling, deleting the folder, and installing again?

    Here are the files in question, try putting them in the Generic folder in your RBR install folder, maybe that'll help: https://dl.dropbox.com/u/6335348/Generic.zip
     
    • Like Like x 1
  8. Nothing works!Same issue after the mod fresh installation..Well i think have to download a new RSRBR2012 mod and delete this one.I guess something wrong with the mod itself...Thank guys the help!!!!!!!
     
  9. I think those files are part of the original game. Have you tried reinstalling RBR itself?
     
  10. Yes i did...i spended my day front of my computer to fix this,but nothing.
    As i said before the RBR clear installation is working by itself,but when i install the rs center and i try to click the regular RBR icon,nothing happening just a blue circle loading for 5 sec and after nothing.Also when i click to the rs center,open and i choose car,stage the green light is loading up and then just stay and no game starts.....
    The black screen with the generic pc problem come up,when i uninstall the rs center.And click the basic rbr icon on my computer.
    By the way...the game intro working only!!!!
     
  11. Warren Dawes

    Warren Dawes
    Premium Member

    I have read a few posts from other guys having problems due to corrupted RSRBR2012 download files, especially when it was first released.
    RallyeSim provided a program to allow people to check the file MD5 (basically checks to confirm that the download is correct). The program is a very small exe called VoirMD5.exe. You run it and compare the number for the downloaded file vs the correct number they list in the Download section. Might be worth checking. Let me know if you can't find the checker file there.
    It might also be worth a shot to try one of the alternate download mirrors to get the base RSRBR2012 file.

    I'd also recommend contacting RallyeSim and runnning their diagnostic program, it often resolves these types of problems.
     
  12. Ok guys,here are the messages from my laptop.After i tried everything to fix the issue.

    1. Not enough memory! Switching to the reference rasterizer a software device that implements the entire Direct 3D feature set. But runs very slow!

    2.Warning!Nothing will be rendered!The reference rendering device was selected,but your computer only has a reduced functionality reference device installed! Install the Direct X SDK to get the full reference device.

    3.Could not find GENERIC_PC_Generic xxx_bnk

    So that's what my laptop shows on and on.
    I don't know what i have to do guys.
     
  13. Well, this seems to be related to creating the DirectX device for drawing.
    Actually these message are being created in several spots, but I suppose that it happens right at the start when creating and initializing this device.

    Are you sure that you do not have any interfering programs/mods/plugins loaded?
    Things like Camhack, or that rsrbr-ratio??.exe thing ?
    Some application maybe replaced or put a d3d9.dll in your game folder ?
    I strongly recommend to check for this.

    As your vanilla rbr seems to work if I got it right, it should not be a problem related to your graphics device drivers.

    The crystal ball did not tell me much more, sorry ...
     
  14. Actually i used camhack to my better views in the last time when i played the game,but i turned off before uninstall.
     
  15. And my vanilla RBR working until i install the rs center.After no working the vanilla version too!
     
  16. Warren Dawes

    Warren Dawes
    Premium Member

    Out of interest Matt, can you give us more details?
    eg. what video resolution are you using? what is the native resolution of your laptop?
    Can you post the contents of your Richard Burns Rally.ini file here (should be only several lines)?

    I seem to recall a message similar to this once when I ran RSRBR on a laptop, but it was a long time ago. I think I fixed it by changing resolution but not sure.
     
  17. Ok.I'm using Win7. Sony vaio laptop,Nvidia card,
    resolution is 1366x768 I always change the resolution in the rbr file for 1366x768
    .Guys the HDR mod can cause this problem?...I downloaded the hdr mod and extract in the rbr file before the problem showed up.maybe i did something wrong and messed up everything there?
    Sorry guys about my frustration,but i love RSRBR and i have to play with it..-:))
     
  18. This is what I was talking about.

    These dumb graphics mods are mostly implemented in a poor way and do not work at all or well when used in combination.

    So, sounds like you have found the problem by yourself ...
     
  19. So guys...I deleted the hdr mod,also deleted everything included the rsrbr mod the track pack,car pack and the 4updates. And downloaded again everything also made clear installation ,and i have still a same problem.Click the rbr icon and loading for 5 sec the blue circle and after nothing.
    Sorry guys to bothering you with this issue.Thank you for the help and advice.
     
  20. Fixup ini
    Settings.
    Fullscreenwindow=1
    Fixaspectratio=1
    FixVSync=1
    VSyncactive=1
    centermenu=1

    [Settings]
    Depth=32
    Forcefeedback=true
    Fullscreen=true
    Minedepthbits=24
    Minstencilbits=8
    Particlecquality=high
    Renderquality=high
    Runintro=false
    Runstartup=false
    Sound=true
    Usecubicenivronmentmap=true
    UseEAX=false
    Usesoftwareaudio=false
    Usetriplescreenbuffers=false
    waitretrace=true
    Xres=1366
    Yres=768