1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

[Help] Can't map throttle to HPP gas pedal, looking for file override

Discussion in 'GRID Autosport' started by whaletail, Oct 18, 2014.

  1. I've been unable to map the throttle to my HPP gas pedal (X axis) since the game was initially patched post-launch. After posting about the issue here, and on the official forums, to no avail, I emailed Codies support, only to be told my wheel was unsupported. In fact, I have a CSW V1, which is absolutely supported, upon responding with this info, heard nothing further. Fantastic support.

    Of course, no pedals are on the list, likely because they are all generic, HID compatible USB peripherals, and automatically supported.

    In any case, I can map brake and clutch without issue, and I'm hoping I can override the in-game mapping by directly editing the controller file. Unfortunately, I'm not very Windows savvy, and haven't been able to find a controller.ini file.

    If anyone familiar with GA's controller file might pass on its name and location, I'd be very grateful. Of course, any specific instructions re: setting the throttle to the X axis would be even better, but any help at all is greatly appreciated.

    Henk
     
  2. ouvert

    ouvert
    Premium Member

    I had similar issue and had to solve it with using some vJoy application, it worked perfectly fine .. but eventualy I ended up with unistalling that game and now I have no issues at all ;)
     
  3. vjoy application?
     
  4. ouvert

    ouvert
    Premium Member

    http://vjoystick.sourceforge.net/site/
    You map your throttle, brake and clutch to different joystick functions, it adds virtual joystick to your devices and than in game you map throtle, brake and clutch normaly by pressing pedals (games detects inputs from that virtual joystick) ... found it on some DIY pedals tutorial and it works perfectly fine without any delay .. havent find any other solution (not even editing config files)
     
  5. Michael...

    Not sure if you've solved this yet, but...

    I am an HPP user and encountered the same problem...I think I have found a solution, which I hope work for you as well! A complete reinstall like ouvert suggested would also work, but you can fix it without doing that...

    -Navigate to your main GA folder (Steam\steamapps\common\GRID Autosport) and Delete the following folders: imput, system, forcefeedback, as well as the two .exe files. (GRIDAutosport.exe, GRIDAutosport_avx.exe) I'm not sure which files actually does the trick, but it's one of them ;)

    - Now (in Steam) right click on GridAutosport in you games library and select properties --> Local files --> Verify Integrity of Game Cache, which will redownload the missing (corrupted?) files. Re-launch the game and I think you'll find the HPP X-axis is working again :) If the game doesn't immediately recognize it when assigning the control, just keep the throttle pressed...or release and press again. It may lag like this in the menu, but it's fully responsive in game...
     
    Last edited: Nov 11, 2014
  6. @ouvert Thank you for that explanation. I will certainly try vjoy if fer312t's method proves futile! Does vjoy introduce any input lag?

    @fer312t Thank you as well! I will give your method a try this evening, and I hope it does the trick.

    Does this method accomplish something that simply deleting the local content files and reinstalling does not? I only ask, because reinstallation didn't work the last time I tried.

    By the way, thanks guys for doing Codies support's job for them. Responding to my initial email, wherein I painstakingly detailed the problem, my attempted solutions, and listed my hardware (in accordance with a developer post explaining how to receive competent support), they simply included a link to the compatible wheels list.

    Long story short, that their final reply included actual prose was somewhat shocking. That it was utterly unhelpful, of course, was not.

    Thanks again, both of you. I'll report back with the (hopefully positive) results.

    Henk
     
  7. ouvert

    ouvert
    Premium Member

    I didn`t notice any input lag or inaccuracy
     
  8. Did you have to use Universal Joystick Remapper (UJR) to map the pedal axes to your virtual joystick?

    Also, does it matter what device number you assign the virtual joystick?
     
  9. ouvert

    ouvert
    Premium Member

    yep I believe so .. UJR + vJoy ... device number shouldn`t matter ... there are videos on YT with guide how to make it work ...
     
    Last edited: Nov 24, 2014
  10. I thought UJR might be necessary. Thanks for the clarification.
     
  11. I have a similar issue. But for me I can´t map my brake on my HE Sim Ultimates. They are on the X-axis. Maybe some conflict with the steering ID? If I had installed the new control box it would be as simple as to plug in the brake where I have my clutch I suppose.

    vjoy adds input lag I suspect so I am not sure I want to do that. May be wrong.

    I also have problem with my clubsport shifter. I can only use it in sequential mode if I choose H-pattern I get "unassigned" as buttons when registering them. And it doesnt work.
     
  12. installed vjoy gut it running but with odd bugs. When trying to change button configuration I get inverse button 6 selection all the time. Seem to go a bit better if I press the clutch some!

    I mapped my throttles to y and z axis but they both show as Z? Maybe I run combined pedals now? It does work though. Interesting that there is a clutch+h-shifter option but no way to map the clutch.

    I still can´t map my Clubsport shifter for the H-pattern. Sequential does work still also with Vjoy.