1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC Help! Can't launch after pressing Drive

Discussion in 'Assetto Corsa' started by Kinduci, Mar 13, 2015.

  1. I updated with the patch last night having purchased the dream pack and got to menu's and whenever i click drive screen goes to loading screen for approx 5 seconds and then returns to menu.

    I have uninstalled, removed folder and all contents in my docs & steam apps and reinstalled fresh and still get the same problem.

    Gutted as i was just beginning to enjoy AC. Any suggestions?
  2. Hello !

    Sorry if this feel offensive, but have you tried alt + tab ?

    Because I know as it opens in another window sometimes it stays on the menu !

    Hope this help and again sorry if you know already about this simple windows option ^^
  3. Second solution, verify integry of game files (right click on assetto corsa in steam, properties, it is somewhere there)

    This checks if all your files are the same as what kunos wants them to be on clean installation (maybe you did not delete a specific folder and you don't know), and replace/redownload files that differs from clean setup.
    Last edited: Mar 13, 2015
    • Like Like x 1
  4. Thanks for the reply, i did check alt tab as i know the game switches from launcher to main game.

    I will attempt the verify tonight, have not tried that yet.
    • Like Like x 1
  5. Just to update, i switched on pc/steam last night and the game did another auto update after which all seems to work. So not sure if they released a fix for my problem or just my pc needed a reboot for certain things to take effect.

    Working now though :)
  6. Weird, i had same problem, i found that if i cleared opponent list and re-entered them it would launch, so, i got it but i dont get it.
  7. Glad the issue worked itself out for you. It's the best feeling when this happens haha !

    Cheers mate !