1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GTX970 & Nvidia Inspector issues - don't use Q antialiasing

Discussion in 'Stock Car Extreme' started by tpw, Nov 16, 2015.

  1. tpw


    Like a lot of people I tend to use NV INspector's AA settings which appear to generally be more optimised and give better results than the built in ones.

    Today I replaced my long suffering GTX660 with a shiny new GTX970. After installing the driver I of course immediately fired up my driving sims. Imagine my disappointment when GSC booted to a black screen with the menu music! I'd seen reports of that GSC/970 behaviour in threads on RD, many of which suggested DDU or similar to remove and replace the driver. Before I went that far though I thought I'd just revert NV Inspector to defaults for GSC, and sure enough the game fired up perfectly. After a bit of experimenting I tracked the issue down to the type of antialiasing in NV Inspector: I was using 8xQ, and it seems that any of the AA settings with a Q in them don't work. Switching to 8xS worked perfectly, and with 8xS, 2xSGSS and FXAA the game looks beautiful and runs rock solid at 1080p 60fps (apart from those annoying occasional microstutters on certain tracks).

    Hopefully this might help any of you who may be experiencing black screens after upgrading to a GTX970. The problem is not game specific, any games for which I was using Q AA were affected.
    • Like Like x 3
  2. The 970 and all Maxwell cards do not support that type of AA anymore.
    • Agree Agree x 1
  3. tpw


    Cheers for that Lazarou
  4. With a GTX970 you might want to try DSR. No my setup it looks much better than any amount of AA.
    • Agree Agree x 1
  5. That's what I use on SCE works great.
  6. tpw


    I might have overlooked something but can DSR be run on a per game basis?
  7. JoelGL

    Premium Member

    I believe so, since you can select the resolution per game. ;)
  8. In Nvidia control panel just tick all the resolutions in the DSR drop down menu that are available then then go to SCE config and select the highest resolution you can run and disable all AA in game and in Inspector.

    Job Done.
  9. Marcel Kleene

    Marcel Kleene
    Premium Member

    Unfortunatelly DSR isn't working with Nvidia Surround. :-(
  10. Alex Sawczuk

    Alex Sawczuk
    Reiza Studios Premium Member

    I've just got a GTX 960 and DSR doesn't appear to work very well for me. I'm playing with these settings, which are similar to what is recommended in the Steam guide.


    Edit: I think 8xS & 4x SGSS is still the best for image quality, performance at a stead 100fps or so. You can probably keep ansio at x4 too.
    Last edited: Nov 18, 2015
  11. tpw


    Thanks Joel and Lazarou, managed to work through that and it looks spectacular!

    Alex, I thought DSR only worked for 970/980 cards, but I am probably wrong...
  12. Alex Sawczuk

    Alex Sawczuk
    Reiza Studios Premium Member

    Says DSR support on the box, so I guess it should :D

    My settings are the only way I could reduce the aliasing on the 3d armco on the newer tracks. (All tracks have been updated to have 3d armco btw for future notice)
    • Like Like x 1
  13. tpw


    I threw the kitchen sink at GSC: DSR 2.0 + 4xAA + 4xSGSS and not a jaggie in sight, and still getting 200+fps on an i5/GTX970. Awesome performance.
  14. 1920 x 1080, with 4 x DSR And 2 X Multisample. GSC all on Max. FPS locked on 90 (-90) in .plr
    i5/ GTX970.
    All looks great.
  15. 2xSGSS, DSR, ansio ...?
    @tpw @Bjarne Hansen @Lazarou @Alex Sawczuk ... could you post me (and certainly others too) a screen-shot of your Nvidia Inspector settings please?!?
    switching from AMD to a GTX 970 I admit that I am a bit lost!!!
    so far I have these settings (but not happy with the result at all!):

    does it look alright or did I miss something to improve the image quality?
    BIG thanks in advance for your help!!!
  16. Alex Sawczuk

    Alex Sawczuk
    Reiza Studios Premium Member

    for me, FXAA off, SGSS x4, MFAA probably off too.
  17. Kobay

    Premium Member

    Read the overclock.net article that Alex links above. According to that article, your settings are wrong.
  18. Alex Sawczuk

    Alex Sawczuk
    Reiza Studios Premium Member

    I run this on a GTX 960, I believe some things changed since the article I posted...

    • Beer Beer x 1
  19. THANKS @Alex Sawczuk !!! this screenie is the kind of information I can actually handle! ; ]
    I was having a look at the link you posted earlier in this thread but this is not my field of knowledge and basically I did understand half of what I've read. therefore more afraid of messing things up inside of Nvidia Inspector then to improve any settings.
    well I guess I have to get myself a bit smarter in this field because using your settings is not satisfying. Textures look fine though but I have some ugly flickering going on ... especially the painted lines on the tarmac!
    I haven't touched any of the global settings within Nvidia Inspector and regarding (G)SC(E): GSC Config.exe: Anti Aliasing =none / GSC.exe: Options -> Display -> Texture Filter: Bilinear (although checked up to 8x Anisotropic).
    I guess I'll stick with the (G)SC(E) anti-aliasing or have I missed a crucial setting?
  20. Alex Sawczuk

    Alex Sawczuk
    Reiza Studios Premium Member

    Try putting any level in GSC Config.exe: Anti Aliasing, and texture filter should be x4 or x8.

    I found that if I don't set a level of Anti Aliasing in GSC Config then it does not work for me.