1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GTR Evolution - Why would my machine struggle with it?

Discussion in 'RACE 07 - Official WTCC Game' started by Tariq Gamil, May 4, 2010.

  1. Tariq Gamil

    Tariq Gamil
    Premium Member

    Hi all! I got the demo for GTR Evolution yesterday. Its running fine but something thats puzzling me is that I get a lot of frameskip whenever I put the AA up to Level 3 so I'm a little confused about this. Technically, my machine should be able to handle it no problem according to the Recommended system requirements. I know they're a load of bull most of the time but even if the requirements were slightly higher than that, my machine should still be able to run it fine. So can anyone explain why its struggling?

    This is my system

    OS: Windows XP SP3
    CPU: AMD Phenom II X4 965 Black Edition (@3.42 Ghz)
    GPU: ATI RadeonHD 5850 XXX (GPU: 755 Mhz / Memory: 1125 Mhz) (ATI Catalyst 10.4)
    RAM: 4GB Corsair XMS3 Dominator DDR3 - CMD4GX3M2B1600C8
    HDD: Western Digital WD5000AAKS
    MB: Gigabyte GA-790XTA-UD4
    PSU: Corsair TX650W

    GTR Evolution Recommended System Requirements:

    - Operating Systems Microsoft Windows XP Home/Pro, Windows Vista*
    - Processor 3 GHz Intel Pentium IV or 100% compatible
    - Memory 2 GB RAM
    - Hard Drive 4.7 GB free space
    - 3D Accelerator DirectX 9 compatible graphics card with 512 MB memory
    - Sound Card DirectX 9 compatible
    - Input DirectX 9 compatible Force Feedback steering wheel
    - DirectX Version 9
  2. Dave Stephenson

    Dave Stephenson
    Technical Administrator Staff

    Some people have had issues with the AA on all the Simbin titles, I used to on my old card. I run it at zero in game settings now and force it on through the GPU driver.
  3. Try turning V sync off, my game runs really bad with v sync on.
  4. Install ATI tray tools and set the flip queue/pre render frames to 0. I had this problem an this helped considerably. You can also try setting shadows one notch lower then max. After that you can set the game processes affinity to only use one processor in the task manager by right clicking on the process. You can also set the games priority to high or realtime which might help. Post back let me known if any of that helped.
  5. Tariq Gamil

    Tariq Gamil
    Premium Member

    Well, I tried adjusting the affinity but the game FPS dropped when I set it to one CPU so I put it up back to 4 so its better with 4. I don't have any setting in my ATI Control Panel for that. I loaded it up just now and the strange thing is, there is no frameskip so its puzzling now (Running 8X AA / 16X AF) and all the max settings in between (Super-Sample AA, Vertical Refresh Always On etc.) so I don't know why it was doing it before and not now.