1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GTL and Fanatec CSR not playing ball

Discussion in 'GT Legends' started by Ian Strom, Feb 27, 2012.

  1. My Fanatec CSR arrived today and aside from some design annoyances vs G25 it seems ok I guess. But I have not actually driven with it yet because I am having a problem.

    The CSR 6-speed shifter is calibrated and detected in the Fanatec control panel but GTL does not see any input from it at all!
    On the wheel itself I cannot map three of the four red buttons! (only RSB can be mapped in GTL, not LSB and the other two unmarked ones) ALL of them are recognized in the control panel when you use them.

    The wheel's axis itself is ok, XYAB buttons mappable, and paddles are all seen by GTL.. Just not the buttons I actually want to use! (and I really do need more buttons than GTL is currently letting me use)
    On a more positive note the CSR Elite pedals that arrived last week are good and I have them connected to my PC via USB atm.

    *Edit
    I can use the shifter and those buttons in LFS.. so this is 100% a GTL issue.
     
  2. Tim Ling

    Tim Ling
    It's a million-to-1 chance, but it just might work Premium Member

    I have a similar problem with the G27 Ian, only the top buttons on the wheel are recognised "naturally" by GTL. I have to use the Logitech software for the rest. If there isn't CSR software, try Joytokey http://joytokey.webs.com/download.htm
     
  3. Warren Dawes

    Warren Dawes
    Premium Member

    GTL doesn't support all buttons on Controllers, it has always had some limitations.
    My G25 wouldn't link a couple of the Shifter buttons, and only some of the buttons on my new Fanatec GT3 wheel can't be linked.

    However, the H Pattern shifter should work with GTL. Or at least my Fanatec GT3 shifter did.
     
  4. GTL was able to use every button on my G25, so this is pretty lame. I am going to have to see if it can be forced into working in some manner. :/

    If anyone here uses a CSR.. or really any fanatec shifter(6-speed, not seq) could you please post the key-map section of your PLR? I would like to have a look at it. I doubt it will help with GTL being retarded but anything that can be tried needs to be checked out.
     
  5. If I may double-post/bump; In GTR2 I can map everything except gears 5 and 6. And as I mentioned before, LFS saw everything. Racer also seems to like this wheel well enough as does forza 3. (though my xbox died again a couple hours ago..)
    Volvo the Game does not support man-shifters but was able to see all the other buttons.

    I am going to go out on a limb and say that simbin did it wrong.
    Also, when I leave the track in GTL, GTR2 and VTG the wheel gets cranked to one side or the other and stays there pushing against the stop. (IIRC GTL = right, GTR2&VTG = left)
    To stop it from constantly pushing I have to do something that involves FFB, so open the properties for it and hit the FFB test button thing.

    I am not impressed. This is really frustrating because GTL has been the only game I have been playing at all lately and the BOSS series is upon us.

    In addition, my normal chair flops back too far and the wheel rim completely blocks the road. With the G25 it only barely blocked the road. Granted, I had to keep my fingers separated to see at certain times on a hilly track but that was doable and ok. I do not have any other chairs that keep me at an acceptable angle to both see and allow proper pedal usage with the CSR.
    I guess I need a wheel stand. :\
    Someone who is not simbin (and also not codemasters) needs to make a nice TransAm sim with real wheel support.

    *Edit
    I have not yet tried joytokey, but I did dig out an ancient nascar2003 install with Saturday Night Stock Car 1970 mod and some tracks like Mirage.. It sees my wheel's buttons and shifter. With the exception that the H-pattern option does not work, only direct shift.
     
  6. Knut Omdal Tveito

    Knut Omdal Tveito
    Premium Member

    This sounds like the FFB has reversed direction. There is an FFB option in GTL menu called "reverse forces". Try to check that box and see if it helps.


    See these comments here about the shifter and buttons:
     
  7. When it cranks you are not in the session anymore and it remains even after you exit.
    The reverse feedback option has a noticeable effect while on the track but makes no difference while off it. The best way I can start to describe the reverse feedback checkbox is how the wheel likes to centre when you are driving normally.. you reverse that and it does not like to centre.

    I will have to try PS3 mode. Thank you for the suggestion.
     
    • Like Like x 1
  8. Knut Omdal Tveito

    Knut Omdal Tveito
    Premium Member

    Also try out some of the very basic things. Try to replug the wheel, change usb port, recalibrate a few times etc. Just yesterday I solved my brake issue by simply calibrating a few times until it suddenly worked.
     
  9. That is just it though, the wheel is working according to the properties page and other sims. :/

    It is not entering PS3 mode. the manual from the fanatec site and the paper in the wheel's box both say to bring it up in PC mode by holding back button for one second.(until the lines are replaced by a momentary dot in the middle of the display) Then press the connect button and the back button at the same time to enter PS3 mode. I am not seeing any momentary dot in the display and I recently sold my PS3 so I cannot plug it into the real thing as a test.
     
  10. Knut Omdal Tveito

    Knut Omdal Tveito
    Premium Member

    Ah, I forgot this was only GTL problem. Even the FFB is good in other games?

    A few things you can try to change in the Userdata/*username*.plr file (make backup first), under [Controls] section:

    EDIT: Another thread with Fanatic+rFactor here
     
  11. The FFB itself seems ok. It is mostly just that when you leave a track(technically, exit the pits into the games main menu) it wonks the wheel hard in one direction. This really is exclusive to simbin titles. I never thought I would have any significant issues with something made by simbin. :(

    Button hold was already 1
    Num controls does not appearto make a difference.
     
    • Like Like x 1
  12. Knut Omdal Tveito

    Knut Omdal Tveito
    Premium Member

    It sounds strange to me too. Other people are running rFactor (which is basically same engine as GTL) with Fanatec and it works well.

    What about the drivers? Did you uninstall the G25 driver? Do you have the latest Fanatec driver? If you want to use PS3 mode (and if you can find a way to enable the switch) it seems like you have to uninstall Fanatec driver and install Logitech driver and use that for the Fanatec wheel.

    Each time you install/uninstall a driver it could be useful to restart the PC before installing a new driver in order to update the registry
     
  13. Roland

    Roland
    Premium Member

    I cannot help you with a solution, but for what it's worth, my G25 does the exact same thing in GTL, even when returning to the box without leaving the game. As I use 900° rotation, this issue has put me on the start grid several times with my front wheels turned way left without me realising it..:confused: Also, like Warren, some of my G25 shifter buttons are not recognised.
    Just so you know it's not a Fanatec exclusive issue..:(
     
    • Like Like x 1
  14. I did not uninstall the logitech drivers, but it does not detect a wheel and will not let you use it so I doubt it is a problem.
    I have the latest fanatec driver version 115.

    The Fanatec driver has been uninstalled the the logi profiler sees the wheel.
    Not the best solution but it should work for now. thank you for your assistance. :)
     
  15. Warren Dawes

    Warren Dawes
    Premium Member

    Just to add, I also get this with GTL and my Fanatec GT3 Wheel (and I also had it with the G25). The good thing with the Fanatec wheel, it is easily fixed, I just switch the off /on button.
     
  16. Hiroshi Awazu

    Hiroshi Awazu
    Off Topic Moderator

    Good to know all this, thanks guys! I have not tried GTL or GTR 2 yet with my CSR but if a problem arises,I'll know what to do.
     
  17. I would like to add that with the CSR in PS3 mode I do not have simbin titles cranking it when you leave the session/race. So that is nice. I did not ever have that issue with my G25 either.