1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GT Legends Windows Vista Patch

Discussion in 'GT Legends' started by Bram, Jun 5, 2008.

  1. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

  2. OK as usual with my GT Legends I get the same old boring message here

    Let me run it through to suggest help:

    I install fine, am running 32bit Vista no worries with Race 07, R-Factor etc

    Click on icon to play and I get a "to install the application you must have admin privs, which of course I have.

    I have tried updating the Starforce thingy and also removing it but no joy

    It says "there is no software for you to update/remove!!

    THe genius of this system astounds me, totally unusable software!
     
  3. Warren Dawes

    Warren Dawes
    Premium Member

    I had similar problems and solved it following this advice:

    I had to install the game with the User Account Control turned off in Vista. For some reason, Vista doesn't like GTL with User Account Control turned on.

    "Go to control panel / User Accounts. Where it says make changes to your account, go down to the last line: "Turn user account control off or on" Turn it off and you will no longer have this problem and be able to install this game"

    Also, maybe this thread at RSC may help:

    How to: Install GT Legends on Vista Ultimate 64 bit - NoGripRacing

    I have to comment that I am not exactly in love with Windows Vista at this stage.
     
  4. Get in Warren

    Thanks so much mate, that helped to sort it out

    I even managed to install my old copy of GTR aswell

    Had some excellent fun having a blast

    I think it may help that I am only running 32 bit maybe?
     
  5. Hi - apologies for bumping an old thread, but I've exhausted all other avenues...

    I signed up for a GTL event, so installed GTL for the 1st time since I upgraded to Vista. Install went fine, then I got the "Starforce incompatible with Vista" message when I rebooted, so I updated Starforce using the update tool. I have updated GTL to 1.1.0.0 and I have UAC turned off in CP. However, when I try to load GTL, it does the Starforce check, then the screen turns black, as if loading, but a couple of seconds later, the screen flashes and I get a "GT Legends has stopped working" message and I'm back to the desktop.

    I'm running Vista 32bit Ultimate Edition. Does anyone have any suggestions?

    Thanks in advance
     
  6. Warren Dawes

    Warren Dawes
    Premium Member

    Have you checked that your virus scanner or fiewall isn't blocking it GTL or starforce?
     
  7. I got it going on Vista Ultimate no probs ... not gloating, just letting you know it does work.
    You tried changing the default graphics settings for GTL before starting it? (Start - All Programs - 10tacle - GTL - Configure GTL)
    Try something quite low to start with (800x600) and see if it fires up.
     
  8. Tim Ling

    Tim Ling
    It's a million-to-1 chance, but it just might work Premium Member

    Have you been to the Starforce website and updated Starforce? I had to do that for Vista, as well as the GTL update
     
  9. Guys - thanks for all the suggestions. I finally got it working! The problem was being caused by a PS2 pad adaptor that I use for Pro Evolution Soccer. Once I unplugged it, the game loaded fine.

    The moral of the story? Always read the crash log!