1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GSCE v1.15 Bug Report thread

Discussion in 'Stock Car Extreme' started by Renato Simioni, Mar 28, 2014.

Thread Status:
Not open for further replies.
  1. Renato Simioni

    Renato Simioni
    Reiza Studios

    Please concentrate your bug reports on this thread.

    If you may please elect to adapt the following report form below:

    Track & Layout Used:
    Car Used:
    Applicable Settings:
    Steps to reproduce:


    Track & Layout Used: Montreal 88
    Car Used: Formula V12
    Applicable Settings: n/a
    Report: After losing front wing the car gets airborn above around 100mph.
    Steps to reproduce: Crash and lose front wing, drive fast ;)

    For any difficulties related to installing, running or setting up the game which are not necessarily bugs in the software, please use the v1.15 release thread.
  2. Sound Bug:

    Track & Layout Used: Montreal 1988 (but also applies on all tracks)
    Car Used: V12 Jean Allegro
    Applicable Settings: Test day, any settings.
    Report: The sound stutters constantly at all times. I can stop it by going to GSC config and switching on Vsynch, but it is there all the time if Vsynch is off.
    Steps to reproduce: It also happened in v1.10 but could be cured by using a process manager utility or Windows task manager, just switching the game to a higher priority was enough to fix it, but with the update to v1.15 this fix no longer works.
    Not the end of the world as switching vsynch on fixes it, but it would e good to be able to test framerates occasionally and not be forced to have vsynch on.

    (i7 4660k @ 3.5ghz, 8gb ram, HD7950 3GB, realtek integrated sound, all drivers up to date, Windows 7 64bit).
  3. Rob Fitness

    Rob Fitness
    Premium Member

    Hi, thanks for the update...
    i just noticed that it "appears" to still not be using all cores from running the .exe
    I still had too ALT+ESC and set affinity to all in task manager.
  4. I'm having problems finishing the update via GSC Sync. I have 247,23MB left and it has stopped three times already and once it said 'user aborted'. I didn't stop it manually nor did i abort it. What's the problem ?

    *additional info: Also when i run GSC.exe from the GSC2013 directory i ran GSC Sync from(my main GSC2013 installation with some modded tracks/cars/mods), it still says v1.10 and there is no sign of any new content, even though i've been downloading for 2,5 hours.

    *edit: Went fine now. Apparently the modded Camaro skins i had installed were interfering. After restoring them with default ones Sync finished smoothly and all the content appears to be there. :thumbsup:
    Last edited: Mar 28, 2014
  5. Does it work if you add +fullproc at the end of the launch path in your shortcut?
    • Like Like x 1
  6. Tobbe Bergman

    Tobbe Bergman
    @ Simberia @Simberia

    Last edited: Mar 30, 2014
  7. Thank you Jan Mikuž posting the solution. I had same problem but after deleting the costum skins sync. finished successfully. :)
  8. its not a bug, but i have FPS issues after the update to GSC extreme. Is the game now this hardware demanding?

    GSC 2013: above 100 FPS
    GSC Exreme: about 25 - 45 FPS

    GSC sync did the job without problems, but should i re-download the game and try a fresh install?
    • Agree Agree x 2
  9. Renato Simioni

    Renato Simioni
    Reiza Studios

    It should not have become more demanding by any noticeable amount. Can you provide your specs and settings so we can try to pinpoint where the issue might be?

    A fresh install should not be necessary but it never hurts, specially if you had a lot of mods added to your previous v1.10 install.
  10. Hi, i try a fresh install first, and then report back. i had a lot of mod tracks installed in v1.10
  11. I can confirm this, using no mods at all and a standard install, updated with sync.

    No other software showing the issue...

    Worked before the update, now when starting the software it pins itself only to the first CPU core, causing stuttering and some major drops in framerate as everything is run on the same pipeline. ALT-TAB and assigning it to all cores removes the issue.

    As i said, no mods, clean install.

    Latest NVidia WHQL drivers
    GTX680 OC
    I5 3570K @ 4.2Ghz.


    One software showing the exact same issue - rFactor 1

    +fullproc does nothing anymore, still pins itself to one single core (core 1 there as well).

    Maybe NVidia issues?

    Update again:

    Managed to fix rFactor by creating the shortcut again. Tried to do the same with GSC but still only one core used... So maybe not NVidia bug afterall...
    Last edited: Mar 28, 2014
  12. Further testing shows that the single core bug is definitely a GSC thing. Reverted my Nvidia drivers and no improvement. It's something in the update i reckon... The rFactor thing was just a freak thing and unrelated, turns out i had not reset settings when updating drivers a while ago.

    So the performance crippling one core lock remains as a GSC bug i am adraid.

    Also seeing some higher gpu usage with smoke and dust, with dust clouds being a real performance hog. This was not seen before the update either...

    And also, even if selecting all cores in process manager, it still only improves it as far as using two cores, never more...

    I seem to recall much better spread across the cores prior to the update as well.

    So yes, seems like a bug.
    • Agree Agree x 1
  13. Kurupt CDN

    Kurupt CDN
    Sector3 Beta Tester

    When I use the gsc sync it seems to gather and dl all the needed content but iam still stuck on 1.07v ?
    Any suggestions
  14. Same problem for me, I used to get very high (200+) frame rate before Extreme, now it is down to around 60-80. Montreal is very jerky even with no other cars on track and replay is like a slideshow, unwatchable.
    • Agree Agree x 2
  15. +fullproc makes no difference on my pc
  16. Alex Sawczuk

    Alex Sawczuk
    Reiza Studios Premium Member

  17. JoelGL

    Premium Member

    What's GSC extreme, vs GSC2013? Still syncing, speed's too slow.
  18. how can i assign more cores to the game?

    strangly the problem is now also in GSC 2013. did a fresh install of the 2013 version, and also low framerate.
  19. I would suppose it does, because if i do it manually from Windows task manager/process explorer it certainly fixes it for me, albeit some microstutter remains with the AI and still only two cores used, whith the rest idling. But the massive performance drop is improved a lot by manually changing affinity.
  20. With the game running, CTRL ALT DEL and start task manager. Under processes find the GSC process and right click it. There shoud be an option for CPU affinity there, set it to All Cores.

    Maximize the game again.
Thread Status:
Not open for further replies.