1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GSC won't launch

Discussion in 'Stock Car Extreme' started by Peevee88, Aug 23, 2015.

  1. Hi

    Have installed GSCE on a remote server (Rackservice) through steam.
    But when I launch the game it does not happen and creates a dump file attached
    Also cannot launch Configuration Tool and Dedicated Server Tool crashes when I click Load Track
    Any ideas how to sort this out - plan is to run my own remote server with GSCE

    Cheers

    PV
     

    Attached Files:

  2. Fabio Rodrigues

    Fabio Rodrigues
    Reiza Studios Community Manager

    Sometimes the config tool won't launch through Steam - have you tried using it manually? (that is, navigating to the install folder, which is usually C:\Program Files (x86)\Steam\Steamapps\common\Stock Car Extreme)

    The same applies to the dedicated server - it's usually more stable to try to launch it manually than through Steam.
     
  3. I have tried doing it both ways and each time it fails on the final stagewhen I click load track
    Attached are screengrabs of the step by step process which ends with a crashdump file
     

    Attached Files:

  4. Very frustrated with trying to host GSCE on remote server hosted by Rackservice who have excellent support but cannot give answer why this is happening with Raceroom and GSCE
    • Assetto Corsa = multiplayer (MP) working fine and seamless
    • Raceroom = MP frustration cannot get it to work
    • GSCE = frustration cannot get it to work
    Here is link to over a dozen GSCE dump files (in one zip) file here: http://download.yallaf1.fastmail.fm/GSCE-crashdump.zip
    It would be cool if Reiza support could shed light on what's going wrong and how to fix - I am sure it simply a tweak to get it sorted...
     
  5. Amazed that the remote server setup for GSCE is so rubbish - or no one has a solution to this.
    Fabio given some suggestions via PM but no solution, honestly disappointed at the lack of suupport resolving this issue
    Have Raceroom and AC working fine on the Rackservice server but my go to sim GSCE not happening and not even solution in the pipeline
     
  6. I don't understand about servers, but our in EEC works perfectly, sending @PATR10T a message to this thread, hope he can help.
     
  7. @Will thanks mate
    As I said I am sure its a settings tweak but that no one from Reiza appears to give a damn (except Fabio but has no solution suggestions that have worked) is quite annoying...
    However must be honest GSCE multiplayer servers are generally empty - while AC are buzzing so might just dump GSCE and focus on AC
    However being a stubborn bastid I would still like to have a way to run GSCE on the Rackservice server I have going
     
  8. If you wanna race online in GSC go for leagues. If you want public server then yeah go for AC, a lot more casual than GSC so...
     
  9. dont use steam for a server! you can download the normal game to your server http://game-stockcar.com.br/downloads-2/?lang=en use the sync to update it to the latest version and run the dedicated server exe

    you dont need a key to run a server ;)
     
  10. Fabio Rodrigues

    Fabio Rodrigues
    Reiza Studios Community Manager

    Hello Paul,

    I've replied to your message - as it happens, with the same suggestion Patr10t made. Please don't misunderstand the lack of Reiza replies as "not giving a damn" - I'm the community manager, and it's my job to try to troubleshoot these issues. This includes communicating with other Reiza members - the fact that they haven't posted here doesn't mean they're not aware nor that they're not trying to help as well :)
     
    • Like Like x 1
  11. Okay maybe we have reached a solution!

    Thankyou Patriot and others who helped here.
    Originally I installed GSCE on remote server using Steam. I uninstalled everything and re-using files found here: http://game-stockcar.com.br/downloads-2/?lang=en
    And the first time I fired up the server it worked fine. Relief & Smiles!
    So may I suggest somewhere in the documentation http://game-stockcar.com.br/faq-2/?lang=en
    Under troubleshooting maybe add a line saying:

    If running a remote/dedicated server do not use through Steam, but rather do a separate install of GSCE using the files here: http://game-stockcar.com.br/downloads-2/?lang=en

    Cheers
    PV