• "Mwoah" - Kimi Räikkönen
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

GSC Extreme - Can't accelerate What am I missing?

Discussion in 'Stock Car Extreme' started by Mikepiper1, Feb 24, 2015.

  1. Mikepiper1

    Mikepiper1

    Messages:
    6
    Ratings:
    +4
    I am currently running GSC Extreme v1.25
    My Setup:
    Fanatec CSW v1
    HPP Simulation Pedals

    When I go out on track I can rev the engine but the car will not accelerate. And yes, I do have it in gear.
    In the control menu, the gas, brake, clutch and steering all appear to be working fine but when I go out on track the car will just rev but won't move. I've used the AI to get the car to move but when control is given back to me, the car won't accelerate. What am I missing?

    Any thoughts?
     
  2. Msportdan

    Msportdan
    Banned

    Messages:
    2,673
    Ratings:
    +497
    u want to use clutch and full stick shift?
     
  3. Fabio Rodrigues

    Fabio Rodrigues
    Reiza Studios Community Manager

    Messages:
    670
    Ratings:
    +421
    Did you check the Difficulty menu? Turn off auto pitlane, etc.
     
  4. Msportdan

    Msportdan
    Banned

    Messages:
    2,673
    Ratings:
    +497
    was gonna say turn on auto clutch if not using a clutch,
     
  5. Mikepiper1

    Mikepiper1

    Messages:
    6
    Ratings:
    +4
    Well I feel like an idiot!
    Tried all of your suggestions and it works now:thumbsup:

    Thanks for the help guys!!
     
    • Like Like x 1