1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. #GiveAwayFriday. Win a copy of F1 2017 - The Game. Click here to join.

GSC 2013 crashes after a while

Discussion in 'Stock Car Extreme' started by Jimmy Larsen, Nov 25, 2013.

  1. Jimmy Larsen

    Jimmy Larsen

    Messages:
    6
    Ratings:
    +1
    After playing for 10-15 minutes the game crashes and make the computer cut the connection to my screen.

    I have tested with other games - iRacing, pCARS, Asetto Corsa, ARMA3 and others. For as long as up to 45 minutes. And with absolutely no problems.
    But after starting GSC2013 it cuts the screen connection after 10-15 min and i have to reboot computer....
    My graphic setting is medium to high....as it is in other games.

    I also made a benchmark test (3DMark) - no problems at all...

    My basic specs is : Win7 - 8GB rams - Nvidia GTX650Ti 2GB -

    Any suggestions ?!
     
  2. Lyndon Hughes

    Lyndon Hughes
    Grandad

    Messages:
    71
    Ratings:
    +15
    Hi Jimmy

    Have you tried starting and running the game as admin,im running windows7 and had a few problems starting normally i then started running it as admin and its been fine since,might be worth trying if you havnt all ready done so.
     
  3. Keith Windsor

    Keith Windsor

    Messages:
    1,764
    Ratings:
    +587
    Must admit, although the game generally runs fine and at good high fps on my system, I seem to have some instability problems I have never seen before in previous GSC versions or in other sims.

    Occasionally after about 30 minutes of racing my sound cuts out completely for a few seconds, then returns. This might happen twice during a 50 minute race but then is fine again.
    Also, similar to above post, sometimes I quit the game and one of my three screens remains black and will not return to the desktop. I can either reset computer or restart the game and shut it down again and it corrects it.
    Both are weird problems I have not seen before, but only very occasional so has not spoiled enjoyment so far.
    (AMD Phenom ii 960t 3ghz quad, 8gb ram, Windows 7 64bit, Sapphire HD7950 3gb, 3 x 22in monitors in eyefinity).
     
  4. Kris Migut

    Kris Migut
    Premium Race Ban

    Messages:
    101
    Ratings:
    +46
    I had a similar issue yesterday, the screen was frozen completely with the sound in a loop. I had to manually reset the computer. So far it's only happened once, and I did not have this issue before the 1.10 update.
     
  5. Jimmy Larsen

    Jimmy Larsen

    Messages:
    6
    Ratings:
    +1
    I will try run as admin......ill get back with result...
     
  6. Jimmy Larsen

    Jimmy Larsen

    Messages:
    6
    Ratings:
    +1
    Well that didnt help....running as Admin that is....

    4 minutes and screen went black.....
     
  7. Jimmy Larsen

    Jimmy Larsen

    Messages:
    6
    Ratings:
    +1
    @ Keith - Btw, i have also have the same AMD cpu as you.........
     
  8. Steven Poirier

    Steven Poirier

    Messages:
    6,554
    Ratings:
    +2,894
    Thats why i will never buy a game from independant team dev and only on online purchase mode ;)
     
  9. Lyndon Hughes

    Lyndon Hughes
    Grandad

    Messages:
    71
    Ratings:
    +15
    sorry y suggestion didnt help
     
  10. Keith Windsor

    Keith Windsor

    Messages:
    1,764
    Ratings:
    +587
    ? I don't understand. If you never buy games that are only downloadable online, then you are missing some great games, and what are you even reading this for? Is that why you are still playing GP4?
    Aside from that, it is off topic and no help whatsoever, thanks.
     
    • Like Like x 1
  11. Steven Poirier

    Steven Poirier

    Messages:
    6,554
    Ratings:
    +2,894
    Nope still playing F1 2013 ^^
     
  12. Kurupt CDN

    Kurupt CDN
    DirtT Tuned Motorsports Premium

    Messages:
    1,556
    Ratings:
    +1,063
    I've been having a similar issue with the wtcc 12 mod I can run a practice, quali start the race but the game usually crashes on the first corner and the sound gets stuck in a loop resulting in system reboot
     
  13. Jimmy Larsen

    Jimmy Larsen

    Messages:
    6
    Ratings:
    +1
    So....no sollutions...?!

    Too bad......wasted my money then......
     
  14. Tim Ling

    Tim Ling
    It's a million-to-1 chance, but it just might work Premium

    Messages:
    2,977
    Ratings:
    +999
    @Jimmy Larsen The only thing I can suggest are the obvious ones...
    1: check & update your graphics & sound drivers. Obviously try the ones from the card manufacturer, not the Win7 updates
    2: uninstall/reinstall the game
    3: try something like GameBooster http://www.razerzone.com/gb-en/gamebooster to make sure there's nothing in the background messing things up for you
    4: uninstall/reinstall DX9 http://www.majorgeeks.com/files/details/directx_9_uninstaller.html

    TBH, I guess you've already tried most of these, but I hope you get the game working
     
  15. Jimmy Larsen

    Jimmy Larsen

    Messages:
    6
    Ratings:
    +1
    Thanks Tim....good suggegions......i will try some of it.
     
    • Like Like x 1