1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Grid 2 doesn't save my controls

Discussion in 'GRID 2' started by Jan Holm, May 31, 2013.

  1. Does anyone know how to get Grid 2 to save the controls ?

    It saves everything else, audio, graphics and son on, but not my controls (G27)
  2. Just a note to say you're not the only one, it's doing it with me too...

    Scrub that, it saved it from when I last played. Try going to the driver details menu and saving your driver details right after you set your controls.
  3. Bram

    Roaring Pipes Maniacs | #27 Staff Premium Member

    Works fine here with the G27 on PC. What platform are you on Jan Holm?
  4. NOT working for me!! :(


    I am using an ECCI 7000 ffb wheel and can set my controls but every time I exit and restart the game my settings are erased. Does it perhaps have anything to do with the ECCI 7000 not being an officially supported wheel?
  5. I use pc and tried to save my profile after setting the controls, but it didn't work.
  6. Bram

    Roaring Pipes Maniacs | #27 Staff Premium Member

    I modified my settings during the second event of the WRS. First one i had to do with keyboard for some strange reason.

    After setting the controls up it saves it for the next time you fire up the game.

    Have you made any modifications to your game maybe?
  7. Hi Bram

    I haven't made any modifications to the game. Just installed it and played. It's very frustrating to start up with keyboard every time.
    have tried to save my profile, but that doesn't help
  8. I have identical problem. Game saves everything, except controler (Fanatec Porsche GT3RS V2 wheel)settings. I just installed the game, no modifications.
  9. Got the same issue here.
    I have to admit, in order to play the game earlier on, i got one of the Cracked Versions from RELOADED Team. Everything worked there.
    Since i have uninstalled it, and downloaded my Steam version, the controls won't save.

    Has anyone a solution for this problem?
  10. The solution is simple. Don't press ENTER when starting the game. Instead press the start key.
  11. Bram

    Roaring Pipes Maniacs | #27 Staff Premium Member

    Works fine for me pressing ENTER, sorry :)
  12. It really depends on your wheel. I have an ECCI 7000 and it doesn't have a "Start" or "Select" button. I *still* have to press the enter key on my kb, but fortunately the wheel still works in-game. Lot's silly controller issues with these EGO-engine based games.
  13. I have figured out, that there is a sirious permission issue with the Controlerfiles. But fortuneatly there is a solution, if you seek for one.

    Yes! You have to change a file, but it won't screw with the ability to save your game progression.
    All you have to do is hard-write the Settings into your "default_controller.xml" or specified controller file, found in "Steam - SteamApps - Common - Grid 2 - System - Controlls" ( What your specified controller file is can be looked up when you chose the "default controller setting" in game. It suggests the right Controllername and all you have to do is look it up inside the folder and change it)

    Just open it and try to figure out, which command you have to copy to the right action.
    Once you saved it, it will be your new default setting. Every setting you will change ingame won't be saved caused by the permissions steam get to write into read-only folders.

    I hope it will be a solution for those of you where the "Start-Button"-Solution don't work.
    It works for me, and now i'm happy that i don't have to worry about my controlsettings anymore :)

    Happy Driving!
  14. Well it remembers my Logitech G25, but does not remember by button assignments :(