1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

gMotor 2 Error

Discussion in 'rFactor' started by Dave Wild, Mar 15, 2011.

  1. Dave Wild

    Dave Wild
    Premium Member

    I have just manually installed the new ORSM V8 mods including the 2010 Add-on season and some of the tracks that will be used in the 2011 season.

    However rFactor will not run, I get the following error

    "gMotor 2 Error.
    Fatal Error compiling pixel shader ps20_blinnBumpSpecMapTOLerpT1VertexAlphaCustom. Please compile offline for more info"

    Can anyone offer any help please?


  2. You are missing a shader from the GameData/Shared folder.
  3. Dave Wild

    Dave Wild
    Premium Member

    Thanks Ryan, however that brings up a possible problem.

    2 of the tracks I added (Pukekohe & Barbagallo) have .PSH and .VSH files for the shared folder and the files have different dates and sizes which are also different from the originals. Which do I use, assuming the shader is for a track and not a car?

    BTW I do enjoy the race videos RD do and your commentary is excellent. I don't know what you are studying at uni but I feel sure you have a future as a motor sport commentator, thanks for the entertainment :)

  4. Thanks Dave - I'm not sure it will matter which shader from which track you use - they were both created by The Lonely.
  5. Dave Wild

    Dave Wild
    Premium Member

    After some logical removal of files, testing and then re-adding files the problem is now cured.
  6. Glad you got it sorted.