1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Glance Right/Left not working

Discussion in 'Assetto Corsa' started by Bernd Tuxhorn, Dec 15, 2013.

  1. Bernd Tuxhorn

    Bernd Tuxhorn

    Messages:
    103
    Ratings:
    +5
    using G27 Button 21/22 for Glance Right/Left I cannot see an effect ingame.
    the default keys on keyboard also dont work.
    someone got this to work ?

    also, I am missing an option to look back
     
  2. Tomaz Selcan

    Tomaz Selcan

    Messages:
    210
    Ratings:
    +100
    You can't look back, only f11 for virtual back mirror.

    I'm using g27 and glance is working fine for me.
     
  3. Juris

    Juris

    Messages:
    299
    Ratings:
    +138
    Not sure if it's the same problem you are having but I cant glance left/right when in cockpit. Other views are fine. I don't remember trying to look back at any stage (I hit enough walls looking forward).

    Can you glance left/right in bonnet or 3rd person. I'm on a t500rs rather than your Logitech G27. Mapping for glancing and dpad in general on the t500 is a known issue. Can you remap them to the G27 shifter buttons or dpad?
     
  4. Cote Dazur

    Cote Dazur

    Messages:
    588
    Ratings:
    +318
    Could be specific to the G27, the glancing works well with my Elite in Cockpit view and also works well fast glancing or slow glancing.
     
  5. Kopiller

    Kopiller

    Messages:
    7
    Ratings:
    +1
    Do you have facetracknoir installed?
     
    • Like Like x 1
  6. Bernd Tuxhorn

    Bernd Tuxhorn

    Messages:
    103
    Ratings:
    +5
    yes, facetracknoir is installed, but I am not using it.
    Glancing is working fine in any other cam, but not in cockpit *(where I want it) - so mapping of the buttons is not the problem.

    btw, there is no sound *(engine, environement etc.) in bonnet and nose cam. Thats a bug ??
     
  7. Chris Matthews

    Chris Matthews

    Messages:
    244
    Ratings:
    +248
    Look left/right doesn't seem to work if you have any viewing software running (such as TrackIR), disable it and all works again
     
  8. Bernd Tuxhorn

    Bernd Tuxhorn

    Messages:
    103
    Ratings:
    +5
    thx for help, but I am not running facetracknoir (its only installed).
    How can I disable TrackIR support in AC ?
     
  9. Anestis

    Anestis

    Messages:
    202
    Ratings:
    +62
    I'm having the same problem with my t500rs(not assigned to dpad).
    Also I have facetracknoir installed but atm i'm no using it with ac
     
  10. Hannes-Joshua Thor Barthel

    Hannes-Joshua Thor Barthel

    Messages:
    184
    Ratings:
    +98
    the problem is that AC detects facenoir or trackir or whatever tracker.. regardless of using it or not, when it'S installed... I had the same problem too.. but because I never used facenoir I uninstalled it and glancing worked fine then
     
    • Like Like x 1
    • Beer Beer x 1
    • Winner Winner x 1
  11. pimenta59

    pimenta59

    Messages:
    3
    Ratings:
    +0
    Sorry for reviving this topic, but I'm having the exact same problem. In the cockpit view, I can't look left nor right. Works fine on all other views.
    The problem:

    I never installed freepie, TrackIr, free track, RealHeadMotion or any head tracking device at all.
    When I first installed, everything was fine. But then, it stopped working.

    I've searched on google, but couldn't find an answer at all, other than uninstalling those softwares/devices, that I don't have.

    Thank you!
    I appreciate any help at all.
     
  12. Marco Versele

    Marco Versele
    Hhmmm, yes ...

    Messages:
    269
    Ratings:
    +56
    Also driving with G27,no possibility to make 'look right/left' working. I deleted the assigned 'look R/L' keystrokes for the keyboard and gamepad to have only the wheel buttons assignments, in case the other keystrokes would have been disturbing the wheel assignment , but it didn't help. I don't have trackIR or trackNoIR installed, no Oculus Rift.
    It's quiet annoying with the restricted view.
    And 'lookahead (look to apex) would have been welcome too.
     
  13. Raikku

    Raikku

    Messages:
    142
    Ratings:
    +20
    You can look back when you press "look L/R" at same time. Just like in other sims.
     
    • Agree Agree x 1
  14. Alvaro de la Orden

    Alvaro de la Orden

    Messages:
    28
    Ratings:
    +26
    Sometimes, the assigned keybinds go nuts, please look carefully the options everytime you launch Assetto Corsa. What's more, maybe you deleted "My Documents" folder in order to try a fresh install and forgot to assign the actions again.
    I have a G25 and sometimes I use a T-IR. I use the paddles to Left/Right view and never had a problem whatsoever.
     
  15. pimenta59

    pimenta59

    Messages:
    3
    Ratings:
    +0
    Thanks for the answers, but I still have the problem.

    I didn't make it clear: I use a Logitech G27 with Logitech Gaming Software, and no matter what I do with buttons, look left or right does not work. It IS ASSIGNED both to the wheels and the keyboard, and none of them work with the COCKPIT view, but both of them work with any other view. I tried re-assigning them, and still the same problem. But if I press the glance left and the glance right buttons at the same time, it looks back, just like it should. Its really annoying.

    And it was working JUST FINE, and out of the blue, it just doesn't work anymore. I didn't even closed the game: I was playing, and then, when I restarted the practice session to switch cars, it wasn't working anymore. I checked that "Lock cockpit camera to horizon" or something like that, did not work, unchecked, still did not work. I didn't install anything, I double checked the "Programs and features" menu in the Control Panel, just to make sure.
     
  16. Radu Oros

    Radu Oros

    Messages:
    1,284
    Ratings:
    +383
    If it works for all views except cockpit, then you still have in your pc software related to real.head.motion app. If you uninstalled already freepie, search for the RHMAC folder, that's where the real head motion app and its settings are located. I'm currently using this app for better head turns, to give a more real motion, and I have to assign in this program look left and look right. screenshot: http://prntscr.com/5l2eg8
     
  17. pimenta59

    pimenta59

    Messages:
    3
    Ratings:
    +0
    I never used it, never installed, I did not know that it EXISTED before looking into the matter.
    Just to inform, I just reinstalled Windows FROM SCRATCH WITHOUT BACKUP, just to be sure I am not using ANY of this, and problem persists.
     
  18. Alvaro de la Orden

    Alvaro de la Orden

    Messages:
    28
    Ratings:
    +26
    How weird, mate. Sorry I have no idea what the problem is.
     
  19. Sebastian Ganly

    Sebastian Ganly

    Messages:
    33
    Ratings:
    +0
    Morning, I am having the same problem. I manged to get the keyboard going while in the cockpit.
    Under control settings -> Advanced at the bottom "combine with keyboard input" I have that checked and I use the ASDW to look left right back and change cameras and it works. Even though I have them bined on the profiler to work on the D-Pad it does not work for some reason.


    Edit:
    Managed to get the D-PAD working. Using the Logitech Profiler, assign the Keystrokes 'ASDW' to the POV. Save the settings to the New Game Profile pointing to 'acs.exe' NOT 'AssettoCorsa.exe' (located steam\steamapps\common\assettocorsa\)
     
    Last edited: Jan 4, 2015
  20. Pablo Cortes

    Pablo Cortes

    Messages:
    326
    Ratings:
    +171
    i fixed this a while back by changing the GLANCE SPEED in video controls, i dont recall if i had to make it slower or faster but that took care of it.

    i couldnt glance left or right from inside the cockpit until this was changed
    maybe its the same problem
    BTW if you press glance left + glance right = look back. :) so there is no need to map a glance back button if you have these buttons mapped on your wheel.