1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Game is not launching

Discussion in 'RACE 07 - Official WTCC Game' started by Omer Said, Aug 5, 2010.

  1. Omer Said

    Omer Said
    Weresloth Staff Premium Member

    Yesterday my hard drive had a BSOD, it did'nt let me open my windows, always rebooting with a blue screen. Anyway, i formatted my hard disk. Later i learnt that it was the result of heavy heating in the chassis. Poor PC :(

    After format, i re-downloaded steam and all Race Series games. Installed them one by one. But now when i click 'launch game' nothing happens. I waited for more than 5-6 minutes nothing happens. No process at Task Manager. Tried dozens of times, still same. Tried opening GTR Evo instead of Race ON, still no sign of activity :( This is driving me nuts. Tried restarting PC aswell.

    I checked out Steam Support forums and there is someone with the exactly same problem, he asked for help but his thread has no reply :D

    Don't ask, i updated Directx 9, all drivers etc...
     
  2. Have you tried lunch it from the desktop ?
     
  3. I had the same problem but when I launch race 07 first the game starts, the next time I can use the Race On shortcut.
     
  4. Omer Said

    Omer Said
    Weresloth Staff Premium Member

    Thank you soooo much mate, this solved the problem :)
     
  5. You better make a game backup with steam on another drive, so the nextime you don't have to download.
    And if you have problems with mods or tracks just deled the race 07 folder and start it again in steam. Steam.jpg
     
  6. Omer Said

    Omer Said
    Weresloth Staff Premium Member

    Thanks mate, yes i learned my lesson after this. Hours of downloading :S