• "Auto racing began 5 minutes after the second car was built." - Henry Ford
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Game freezes trying to join a server

Discussion in 'rFactor 2' started by St3fan, Oct 23, 2016.

  1. St3fan

    St3fan

    Messages:
    698
    Ratings:
    +409
    I signed up for a R2P race, but couldn't join the server because the game froze at the car selection page:
    [​IMG]
    The "rFactor2 is not responding" message disappeared now and then and my mouse cursor reset to the top left corner of the monitor whenever that message disappeared. But the game was still stuck. I kept trying different ways (use Multiplayer to log in on RF2launcher; use Steam server browser; etc) but the game always got stuck on this page, until I eventually missed the quali.

    Then I tried to connect to other servers, and the results were the same. My game just got stuck on this car selection screen and I was never able to join any server.

    Single player works fine BTW, and I used to be able to join a couple RD RF2 races a few months ago (until RDUS stopped using RF2). Any tips? Thanks.
     
  2. Slyfrequency

    Slyfrequency

    Messages:
    998
    Ratings:
    +376
    Is it just this mod you're having problems with? If so maybe reinstall the mod. If the problem keeps appearing, maybe try a reinstall of rfactor 2
     
  3. Gijs van Elderen

    Gijs van Elderen
    Premium

    Messages:
    4,611
    Ratings:
    +2,398
    Verify your install with steam: if this is OK: then your install is OK and a reinstall won't fix it.

    My guess: Unistall all server Vmods.
    "Mods" in the launcher.

    The multiplayer.ini or the player.json might be a cause too. They won't be replaced be a new install. You can cut/past the to desktop (to kerp a back-up) rF2 will create a fresh player.json and multiplayer.ini
     
  4. St3fan

    St3fan

    Messages:
    698
    Ratings:
    +409
    Can't join any server. Not specific to this mod.

    Verify local files didn't work :(

    Can't seem to find it... where is that?

    Tried and didn't work...
     
  5. St3fan

    St3fan

    Messages:
    698
    Ratings:
    +409
    Problem solved! I logged onto the Formula E server once a while ago. I just remembered about this, so I ran the RF2 GO! Updater.exe and then boom! I can log in onto any server now!