• "Auto racing began 5 minutes after the second car was built." - Henry Ford
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Game Crashes D3D Device Error - Help?

Discussion in 'F1 2016 - The Game' started by Nox, Oct 10, 2016.

  1. Nox

    Nox
    Premium

    Messages:
    6,682
    Ratings:
    +2,323
    Hi all,

    So twice now I have come to the last lap of the Bahrain GP in Career mode and had a CTD. The error message reads "The D3D Device has been removed." Does anyone know a fix? bear in mind, I am not PC savvy, so as simple as you explain it, the better.

    Thanks!!!
     
  2. Lazarou

    Lazarou
    Premium

    Messages:
    1,692
    Ratings:
    +1,015
    What GFX card do you have mate?

    This discussion may help https://steamcommunity.com/app/391040/discussions/0/355043117524241125/
     
  3. Nox

    Nox
    Premium

    Messages:
    6,682
    Ratings:
    +2,323
    I have NVidia GeForce GTX 680.

    I'll take a look at the thread, thanks
     
  4. TurcoMaldade_

    TurcoMaldade_
    Premium

    Messages:
    189
    Ratings:
    +114
    I have this problem too.

    Probably is because you are using all your video memory. I use three screen and with my 780TI with 3gb I had too reduce the resolution since the last update because I was having the same problem.
     
  5. Nox

    Nox
    Premium

    Messages:
    6,682
    Ratings:
    +2,323
    I followed some of the advice in the thread Paul mentioned and so far so good, it didn't crash again. I don't know if it will stay that way, but worth trying. I went to my nVidia control panel and under the "Adjust image settings with Preview" tab, I moved the slider a few notches over to the performance side. If it crashes again, I'll try something else, but it seems to have done the trick for now.
     
    • Like Like x 1
  6. Lazarou

    Lazarou
    Premium

    Messages:
    1,692
    Ratings:
    +1,015
    I thought it might be the energy maximum performance setting, but glad you have a fix.