1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Game Crash at 13MPH

Discussion in 'F1 2010 - The Game' started by Christopher Brown, Jun 17, 2011.

  1. As the title states, I start a race and the game freezes at 13mph. 3 days ago, it was fine.
    I have tried a complete re-install, deleting all saves, running the game in dx 9 and dx 11.

    When I get off the game via CTRL+ALT+Delete, I have "f1_2010.exe *32" that takes 20k memory and "F1_2010_game.exe *32" that takes 1,219,348k memory and the process can't be ended.
    This even stops my PC from turning off properly, it will get stuck on "Windows is shutting down" (Windows 7 x64)

    I am now lost as to what to try next. Any ideas?
  2. Sounds like what they call a 'memory leak' - I wish I knew enough to tell you a bit more. =/
  3. Really need help with this, can't play with any mods. Which is really annoying, the base game is so buggy and looks horrible.
  4. lol funny problem
    please provide more details like try to remember if you changed something imporetant in these 3 days on your computer, does this freeze occurs on TT too (or practice, qualify), did you install the latest patch (1.01), and so on, because I cant guess...
    Perhaps it is not related to the speed... try to wait a few seconds on the start and then go progressively, and check the speed when it crashes... if it is 13 again then it has something to do with the speed
  5. I have the game via steam, so I have the latest patch, 4 days ago now, it was running fine, the only thing I changed was adding an xbox 360 controller to the pc.
    It happens on practice, qualify, grand prix, time trial and online.
  6. Turns out it is the Xbox 360 controller that is crashing the PC, even with the official Microsoft drivers for it -.-'
  7. it may be a port or drivers conflct. If possible you could try it on another pc to see if it also crashes.
    Also, try to unplug other usb devices, controlers, wheels, webcams... and use only your xbox controller. Codemaster games use to crash when more than 1 controller is inserted.
  8. This is what happens on a fresh install - no mods, with or without an xbox controller.
  9. Does it always freeze at the same time? What happens on time attack?

    maybe you alread done that but this steps may at least eliminate some guesses:
    1) Before run the game, unplug any usb devices
    2) If you can, force dx9
    3) run the game. On the options menu set audio to software
    4 on the ptions menu set the antialiasing to the lowest value and set the graphics to the lowest possible and toggle vsync (if on put off or vice versa)
    5 on the otions menu choose a keyboard preset
    6 on the options, disable all HUD.
    7 in the garage, before choosing "go to Race" press alt+enter to go to windowed mode.
    8 now choose "go to race " being in the windowed mode.

    edit: you can also try running the game from command line passing -safemode as parameter
    edit2: how many cores your PC is? it seems you are having the bug #27 of this page: http://segmentnext.com/2010/09/23/f1-2010-errors-crashes-freezes-fixes/2/
  10. TIP:
    -Throw PC off the building.
    Problem Solved! (wipes hands)
  11. I had problems with my xbox wireless receiver for PC, after a lot of trying to get it to work, it turns out that it drains power from the USB bus.

    I have a brand new motherbard, but I have to have mine plugged in the front USB port on its own so it has enough power. You can also use a powered hub or PCI USB card to cure that problem, or as said above remove all other USB devices
  12. Good plan....
  13. Wouldn't work: the PC would freeze before hitting the ground...
  14. Hmm, managed to semi-fix my game. Was a combination of corrupt saved data and the audio being set to Rapture3D -.-'

    Now I get 1-3 freezes per 100% race and my game has trouble with mods, i.e. not being able to start a race with some of them.
    Yey :p