• "Mwoah" - Kimi Räikkönen
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

G27 issues on GT6

Discussion in 'Sim Racing Hardware' started by haruhi, Jul 9, 2017.

  1. haruhi

    haruhi

    Messages:
    2
    Ratings:
    +0
    I found a video of what's happening:


    I am having the same issue with my G27 wheel on GT5/6 on PS3 and Assetto Corsa on PC. It starts up fine and works for a very short time during a race before it completely shuts down. The pedals have severe input lag but usually work and the wheel works fine for about 30 seconds before I feel the force feed back shut down and no inputs work anymore. It will start working again if I unplug and replug the USB for the wheel.

    Everything works fine in menus with no issues until I start a race then the wheel gives out and everything dies until I unplug the usb but the problem still persists.

    All inputs work on the Logitech Profiler however I have to hold down the pedals before I see any input. No LED on the shifter and when the wheel cuts out the LEDs freeze in place.

    Any suggestions on what parts could be failing or solutions?
     
    Last edited: Jul 10, 2017
  2. haruhi

    haruhi

    Messages:
    2
    Ratings:
    +0
    Doesn't seem to happen when I disconnect the G27's shifter. When the shifter is connected the LED doesn't light up but it does work however.

    Anyone heard of this happening before?