• "My mind is always racing." - Justin Bieber
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

G27 brake pedal dragging

Discussion in 'Sim Racing Hardware' started by Decenten, Mar 16, 2015.

  1. Decenten

    Decenten
    Driver of the #73 Team OGMRZ Holden V8SC Premium

    Messages:
    2,021
    Ratings:
    +406
    So my G27 started dragging the brake pedal. I recently upgraded the brake spring to the GTEYE progressive spring and now the throttle and the brake are having problems. The brake is on down the straights and the throttle doesnt stay full when put all the way down. Anyway to fix this?
     
  2. Yapci

    Yapci
    Premium

    Messages:
    675
    Ratings:
    +241
    Did you recalibrate them?
     
  3. Decenten

    Decenten
    Driver of the #73 Team OGMRZ Holden V8SC Premium

    Messages:
    2,021
    Ratings:
    +406
    Yep down that even set a deadzone and it still drags. I set it so I had to go past 25% to activate the brakes and it still was dragging
     
  4. Yapci

    Yapci
    Premium

    Messages:
    675
    Ratings:
    +241
    Maybe cleaning the potentiometer solve it...If not I dont know! Sorry m8...
     
    • Agree Agree x 1
  5. SOLO59

    SOLO59
    Premium

    Messages:
    630
    Ratings:
    +509
    I've cleaned my potentiometers, I use a star tech 3.0 usb hub for more usb device accuracy (connected to pc via usb, and to make it stronger, also plugged in to a power outlet), and I use leo bodnar usb cable for the pedals. All three above really helps with the accuracy of the pedals. Without these accessories and cleaning the pots, the pedals are always jumping or slightly pressed on their own.

    If you recently took apart your pedals, make sure to double check to ensure that all parts are placed back tight and firm, nothing should be loose. My gas pedal was jumping, took it apart and found the small spring (not the pedal spring) was loose. So I placed it back firmly. All is ok now, hope this helps. I also have GTEYE installed
     
    Last edited: Mar 16, 2015