1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

PC G27 Brake issue ... Help no sensitivity either 0 or 100%

Discussion in 'Assetto Corsa' started by Brian C Hayes, Sep 6, 2015.

  1. My G27 suddenly has decided to act up (again) ... managed to sort most things out ... except for the brakes .. they are either off or on fully ... no gradual increase ... I lightly push on the breaks and it goes from nothing to max instantly .... any idea on how to fix this ?
     
  2. Dave R

    Dave R
    Premium Member

    Can you clean the pedals Brian? (take em apart and clean em). I've had this issue on my DFGT and cleaning the pedals helped it immensely.
     
    • Agree Agree x 2
  3. Ricoow

    Ricoow
    420 Premium Member

    Also before starting to drive, Always press all pedals to the bpttom before driving to 'calibrate' the usable range of the pedals.
    If this doesnt work then reinstall your drivers
     
    • Agree Agree x 1
  4. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    @Brian C Hayes are you using the default values for the G27 that come with the game, or have you altered them yourself?
     
  5. Hey Guys,

    Thanks for replying ... as you might expect on the official Logitech forum nothing .... So I opened up the pedals and swapped the clutch and brake units over ... thinking if its actually the pedal thats the issue, for the most part ashamedly I do not use the clutch ... Same issue ....so I am guessing its not a cleaning issue ...or a specific pedal unite failure ....

    I noticed that on Assetto Corsa recently ... when I go to do a set up wizard .. the pedals are not recognised ... but when I load an existing profile .. the gas and brake works fine ... ?

    Totally at a loss .. but I sense there is a fix to this .. most likely software ..

    I have gone into the Device Settings - Advanced .. that shows you a graphic for all the buttons ... the wheel and all 3 pedals .... Accelerator and brake one side and clutch showing on the left .... when I depress the gaz .. you can she the gradual increase .. same with the clutch ... but the break is all or nothing ... the slightest push on the brake and its maxed out ... obviously makes driving a challenge

    Any advice really appreciated ... I recently tried reinstalling the gaming software but thats not done anything
     
  6. Dave R

    Dave R
    Premium Member

    Can you add a bit of a deadzone to it?
     
  7. Whats the best way to do that ? ... would that give me any fidelity though ? i
     
  8. Dave R

    Dave R
    Premium Member

  9. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Depending on how old your wheel and pedals are, if you are still within the warranty timeframe and think that the wheel is malfunctioning, make sure to not open up anything, and inform Logitech via email or phone about a broken device and they will ship you a brand new one.

    Once you open up the case though, you warranty is gone.
     
  10. I already modded the brake pedal with a spring, so technically I have opened it so I am guessing my warranty is done, can they tell if you have opened it up ?
     
  11. Somebody is selling the wiring online might give that a go
     
  12. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Good question, I honestly don't know.
     
  13. So I changed the wiring over and on Dirt Rally it works a treat .... Assetto Corsa will not allow me to map the clutch to the break unfortunately .... I suspect this might be a beginning of another expensive wheel purchase..... I wont be going with Logitech ... fantastic when they work but incredibly unstable and non existent support
     
  14. Managed to Fix it .....
    Needed to deinstall the gaming software / you must do this otherwise the calibration function is not available
    then calibrate via settings on game controller
    Then reinstall the gaming software ....
    and Walllayy ....
    Now I just need to open it up and change over the pedals again
     
  15. Thanks for the replies much appreciated