1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

G27 always 900 degrees in AMS

Discussion in 'Automobilista' started by schlitty, Jul 5, 2016.

  1. I apologize if I use the wrong terminology but I'm not the most experienced sim racer. I'm still very new to this stuff;

    I have a G27 steering wheel and out of nowhere I suddenly have an issue with my steering wheel always being 900 degrees of rotation and the saturation always matches the vehicle to the 900. AMS always just worked for me, each vehicle would load its correct steering lock and saturation. But now its a mess. Every vehicle is like driving a bus with the 900degrees. Like if the vehicle has 270degrees of rotation I have to turn my wheel the full 900 degrees to match the full 270.

    I have all my Logitech Profiler settings and in-game settings set to what the manual specifies and always have. I hadn't ever changed them before this situation. If I change my Logitech Profiler settings to a specific degrees of rotation then match that in-game with a 'yes' custom. That's the only way I can get something that feels remotely right. But I have to match it to whatever vehicle I want to drive around and crash. Exiting the game each time.

    I did have an incident awhile back where Windows10/Logitech Profiler recognized my G27 as a Driving Force wheel. But I think/thought I had cleared that up. And I only mention it because its the only thing that has happened out of the ordinary before this situation. So, I dunno. Is there a way to 100% uninstall all traces of a wheel in the registry etc and make sure you have an absolutely clean install? Or am I wandering down the completely wrong path and missing something much more simple and obvious?

    Any tips, suggestions, etc would be appreciated. Thanks!

    Edit: Just wanted to add, the wheel is still working as it should with custom settings/setups for other game like DiRT Rally and F1 2013.
     
    Last edited: Jul 5, 2016
  2. ouvert

    ouvert
    Premium Member

    do you have newest drivers (march 14 2016) ? in R3E not having the new ones causes this issues
     
  3. Dan Marr

    Dan Marr
    Staff Premium Member

    I'm having the same problems with my G29, and I have the latest drivers, I think it might be an issue with AMS not being updated to them yet (unlike R3E, where we had to update so game could adjust them)
     
  4. Jake Fangio

    Jake Fangio
    Please don't rain pleeaassee don't rain

    I have this issue too.I went into the control settings in game and enabled custom steering rotation and then set it myself.I don't know why this is happening now.
     
  5. Well, good to hear I'm not the only one. Bad to hear no solution yet! Hopefully somebody has figured something out. For what it is worth, I noticed the issue more recently than March. Like just within this last month it started happening. Or me noticing anyway. Like I said, I'm still new to a lot of this. But its become a chore to setup my wheel and is detracting largely from my enjoyment of Automobilista. The ease of access and approach is what sold me on this game as my first sim.

    Yes, I have the Logitech Software (profiler) ver 5.10.127 downloaded and installed from the Logitech website.
     
    Last edited: Jul 5, 2016