1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

G25 Deadzones??

Discussion in 'RACE 07 - Official WTCC Game' started by Warren Dawes, Aug 30, 2010.

  1. Warren Dawes

    Warren Dawes
    Premium Member

    Is there any way to adjust Controller deadzones in Race On?
    I haven't been driving Race On much lately, but did a race with the WTCC cars, and noticed that my G25 Accelerator seemed to have a big deadzone. When testing the Controller Calibration in Race On, I had to push the Accelerator to almost half way before any signal showed. The Brake seemed to be also similar.
    When checking all of the Controller Options, I can't see any way to take out some of the Deadzone so that the Pedals have a more even response.

    Have I missed something somewhere, or is this a sign my G25 is having a problem?? :confused:

    EDIT: Strangely, if I check the calibration in the Logitech profiler, there is no obvious deadzone. Also, testing it with GTL and RBR, I have no deadzone, only with Race On.
     
  2. Yves Larose

    Yves Larose
    Premium Member

    Warren if you look in the second screen of the controller set up you'll see the deadzone options

    Edit: i also have that big deadzone but actually i think the Race 07 display is not right, the deadzone when i play doesn't seem that big or its just that i,m use to it.
     
  3. Warren Dawes

    Warren Dawes
    Premium Member

    Thanks Yves, don't know how I missed that Option, but I was looking for it under Options in the Race section. It is available in the Main Screen Options.

    Unfortunately, after checking, I already have my deadzone set to 0 anyway, so can't do any more I guess. The big deadzone was very obvious to me when driving the WTCC car (Chevy 07), nothing would respond until I pushed the pedal to about 40%.

    Maybe I have been spoiled by playing GTL and RBR where the pedal response is much more linear. I don't recall the same deadzone issue with the GT cars though, maybe it depends which Class of Car is used in Race On??
     
  4. Have you tried reassigning the axis?
     
  5. Warren Dawes

    Warren Dawes
    Premium Member

    That fixed it, many thanks. :thumb: