1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Freeplay in a thrustmaster TX?!

Discussion in 'Sim Racing Hardware' started by EsnN, Dec 5, 2014.

  1. Hey guys!

    I bought a TX racing wheel two days ago and after a few (2-3) hours of driving i started feeling some freeplay in the wheel.

    I checked with both my Formula wheel and the standard 458 wheel and there is the same freeplay: I feel it while driving when I change direction and i really feel it in test the "océan de vagues" (i guess it is ocean of waves in english) in the TX control panel.

    Last thing i checked was to rotate the central shaft without the wheel at respectively 2% and 98% of the stroke (i.e. the point when it becomes harder) and once again I can feel and hear some freeplay. (see the video attached)

    It really feels like something is not tight enough and slips as soon as you provide enough torque.

    Is it f***ed up? Should i contact thrustmaster or the shop i bought it from?

    Thank you very much in advance for you help,

    Esn

    https://www.dropbox.com/s/tyn20s86e7312lx/TX_problem.mov?dl=0
     
  2. Humzah Hussain

    Humzah Hussain
    Godspeed!

    I would say get into contact with Thrustmaster, I've had my TX for almost a year now and not had this sort of issue with it. You could, if you want to, open up the base and try to see what is going on inside. That should give you a better understanding of what is going on and you never know you may be able to find the source of the problem.
     
  3. I'm not aware of any free play in my TX either and its been well over 6 months now.