1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Formula Truck won't recognize Clubsport pedals ?

Discussion in 'Formula Truck 2013' started by Don Menary, Sep 7, 2013.

  1. Anybody else have this problem ? They work great in every other sim I run . ( iracing , Rfactor2 , ET2 ,netKar Pro ).
    They worked on FT 2012 when I was running XP , but I upgraded to Win 7 and have not been able to assign pedal functions in either 2012 or 2013 versions.
    Game Stock Car won't even start for that matter, but that's another story.
    Had one e-mail correspondence with Reiza and that was it .
    I really want to get formula truck running again as it is just a great sim.
     
  2. Warren Dawes

    Warren Dawes
    Premium Member

    I have CSP ver 1 pedals and they work fine with FTruck. I'm also using Win 7 64.

    Not much help to solve your problem though. :unsure:

    Have you installed the Win 7 ver software for the pedals? (or the 64 bit / 32 bit ver depending on your version of Win 7)

    Are you running the game as Administator?
     
  3. Yes , Win 7 64 bit , just re-installed the 144 driver .

    Yes I am running as Admin .

    Thx for the reply Warren .
    Just had a thought , ( I get them once in a while ) do you have your pedals plugged into wheel base or into PC USB ?
     
    Last edited: Sep 8, 2013
  4. Warren Dawes

    Warren Dawes
    Premium Member

    Yes, my pedals are plugged separately into the PC USB.
     
  5. Calum McLure

    Calum McLure
    Did ye, aye? Premium Member

    Have tried just unplugging them and then plugging them in again? Occasionally my CSR Elites don't get picked up by various sims and that usually sorts it.
     
  6. Yes , I normally run Clubsport wheel and pedals , and DSD shifter out of a powered Usb hub . I have tried running the pedals out of a front PC port as well as a rear port . No go !!
     
  7. Warren Dawes

    Warren Dawes
    Premium Member

    Do the pedals show up ok in the Porsche Wheel Calibration software?
    Do they work ok in other Sims?

    Try plugging them in to your USB slot before the Shifter, I have sometimes found mine won't register if I plug the pedals in last.

    It seems strange to me, they certainly should work ok in FTruck. :confused:
     
  8. Pedals show in the Fanatec property page , vibration test even works . No issues with any other sim . They worked fine with the original install of FT 2012 when I was running XP.

    It has been since I've re-installed FT 2012 and 2013 on Win 7 that they have not been recognized in only Formula truck . I am wondering if I should delete both versions of FT and do another download and install of just 2013 version ?
     
  9. Warren Dawes

    Warren Dawes
    Premium Member

    Since this is the only sim it won't work with, I'd be inclined to remove the previous installs and try a fresh install of FTruck.
    Make sure to not install it to C:\Program Files or Program Files (x86). I installed mine to E:/FTruck 2013 but anything outside Program Files should be ok.

    I have both FTruck 2012 and FTruck 2013 installed and both recognise the pedals ok.
     
  10. Calum McLure

    Calum McLure
    Did ye, aye? Premium Member

    Do you have any other controllers/pads plugged in by any chance? Another thing I always do is leave my Xbox pad plugged in and that overrules the wheel.
     
  11. I have a Razer Xbox style controller and have tried it with and without it being plugged in . Makes no difference .
     
  12. I put all of my driving/racing sims on F drive in a folder Racing games. C drive is for flight simming .

    So I think I will delete all of it , re-install it to F drive but outside of Racing folder.
    I am also not sure if I got a clean download from Rieza , files missing maybe ?

    Something always shows up as a virus from them . Will try this on the weekend and let you know how it turns out .

    Thanks for your time Warren and Calum .
     
  13. Warren Dawes

    Warren Dawes
    Premium Member

    Don, try re-installing with your virus scanner turned off. Sometimes they can cause problems by reading clean files as "suspect" and blocking them.
    Your previous install location sounds ok though.
    Are you able to re-download the FTruck2013 as well as re-installing it? (Just to be sure).
     
  14. Yes I can re-download and install , but for sure will do it with anti virus off this time !
    I just un-installed through control panel , but there are still game folders on the drive . Will I have them all by deleting them or are there any elsewhere to your knowledge ?
     
  15. Warren Dawes

    Warren Dawes
    Premium Member

    Don, if you delete any remaining files in your FTruck folder, then that should be all of them.
    Also delete your FTruck folder as well, just to be completely sure everything is gone.
    Anything else left on your F Drive should be ok.
     
  16. Hey guys , I got it working !!
    After d/ling a second time , I got a clean install from sim-racing-evolution.fr.
    Calum you were right about the controllers. I had a Logitech G13 plugged in which I realized I did not have when I was running it in XP .
    So I unplugged everything except the CSW and pedals , G13 was still showing in the Fanatec property page , did a PC restart , G13 info gone , fired up Ftruck , voila wheel and pedals recognized ,now I close FT and add my shifter back in so there is only wheel , pedals and shifter showing in Fanatec property page , go to controls in FT and assign pedals and shifter , buttons and it all works . whew !!
    So , I guess Formula Truck only recognizes 3 controllers , where iRacing or Rfactor2 sees more . For some reason it was seeing the G13 before the Clubsport pedals ? Strange .
    Thank you so much for your help Warren and Calum , you got me thinking in the right direction ! I was baffled .
     
    • Like Like x 1
    • Winner Winner x 1