1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Force Feedback issues like none else on the internet.

Discussion in 'Richard Burns Rally' started by BlazeGT3, Feb 7, 2013.

  1. Hello!
    Thanks in advance for any help I can get with this.
    I have looked for 2 weeks, using every combination of searches I can think of.

    I have a Porsche Gt2 Fanatec wheel with the latest firmware, running 32bit windows xp.

    I bought and installed RBR 3 weeks ago, and have no force feedback whatsoever.

    When I try to go to the force feedback options within RBR, (under setting>controller>forcefeedback) the force feedback is grayed out and I can not select it, it hops from controller setup to filters.

    I have done everything under the moon that is listed on the internet. I have made sure the driver is working correctly, I have done the regedit thing,
    I have gone into the RBR.ini file and changed any setting that could help me, I have updated all of the RBR patches, and still the force feedback option is grayed and I get no response in game.

    Thanks again,
    Blaze.
     
  2. Ole Marius Myrvold

    Ole Marius Myrvold
    JWB 96-13 Staff

    I did have the same problem for quite a long time. However, it worked when I innstalled the game. Then the 1.02 patch and started up. Nothing else.

    Have you tried that approach? Just innstall the game, than the patch. Then start.
     
  3. Sadly it did not work.

    Thank you for the suggestion!
     
  4. Ole Marius Myrvold

    Ole Marius Myrvold
    JWB 96-13 Staff

    Meh, then I used my only tip :(
     
  5. Warren Dawes

    Warren Dawes
    Premium Member

    I know this doesn't help, but just to confirm.
    I use a Fanatec GT3 v2 with Win XP 32 and the FFB worked fine, from my first install, I did nothing special. So your wheel should work.
    I use the Firmware that came with the wheel (ver 115 I think).
     
  6. It's good to know it's not Fanatec! Thanks for the tip, I am not sure why I am having this problem unless it was a problem with the disk from SCi Games.

    Blaze
     
  7. Michael Nelson

    Michael Nelson
    Premium Member

    Just had a quick search of the Rallyesim forums to see if anyone else had your issue.

    I found this:
    http://forum.rallyesim.fr/viewtopic.php?f=6&t=13209&hilit=volant+fanatec&start=15

    Which implies that the latest beta driver does not work for RBR. This would explain why it works fine for Warren, but not for you, as he could be on a different firmware.

    I'd download the latest official version of Fanatec firmware, and try that. If that doesn't work, maybe even an earlier official version. (An official version released prior to September 2012, should work)

    Good luck.
     
    • Like Like x 1

  8. Thanks for doing the research and for the help.

    Earlier today I downloaded the latest firmware, and had the results listed in the original post.
    I went to the Fanatec website to download the oldest Firmware, they call it stock, and still no force feedback. The only real difference is the wheel shakes like I am braking when I press the gas :(.

    Now, something that I am not sure of is, Fanatec has firmware, and they have drivers.
    I think I have tried both drivers already, but do you think I should try latest firmware with a older driver? I am not sure which one would effect the ffb.

    Thanks again for all the help.
    -Blaze


    EDIT: Okay, just to be thorough, I tried both firmware with both drivers (total of 3 different combinations) and nothing made the force feedback work, or the force feedback option in the menus work/not be grayed out.

    Poop.
     
  9. Warren Dawes

    Warren Dawes
    Premium Member

    I'm pretty sure I was using Firmware v681 and driver v115.
     
  10. Michael Nelson

    Michael Nelson
    Premium Member

    Is it possible you have some conflicting drivers installed? Did you ever own a Logitech wheel, or some wheel at any point? If yes, have all the old drivers been thoroughly removed?

    Do you have any other gamepads plugged in? Try removing those, sometimes they can cause conflicts.

    You could try the "Redetect Devices" in RBR, but I suspect you've probably tried that.

    According to a post in the thread linked above, this worked for a user with the CSW wheel
    I don't know if thats the registry edit you tried, but if not - it's worth a shot. Your product ID should be different though, given you have a different wheel, I'm not sure what yours is, sorry.

    Those are the only things I can think of, if it still doesn't work you could try flicking Fanatec an email.
     
  11. Warren Dawes

    Warren Dawes
    Premium Member

    I think I read somewhere once of a person having a conflict caused by a special Logitech keyboard which interfered.
    Getting desperate now though, pretty much out of ideas.

    EDIT: I assume you can get FFB with your wheel and another game?
     
  12. This is the only wheel or gamepad I've connected to this computer.

    Sorry, I have gone into the registry before, but I am a little confused on how to do
    "1. Jump to * XXXX = Product ID = 038E CSW CSR / CSRE = 0011 = 0197 PWX 2. Change the value of OEMData to "43 00 88 10 13 00 00 00"

    Thank you for helping, I am straight out of ideas of my own at this point.
    I will try Fanatec if I can't get this worked out by monday.

    Warren I am using a notebook, so no logitech keyboards have been used, but thanks for the help. :)
     
  13. Yes, all other games that use force feedback (i've tried forza 4 and dirt 2 and wrc3) work.
     
  14. Michael Nelson

    Michael Nelson
    Premium Member


    Disclaimer: Don't do registry edits if you don't feel comfortable with it, although unlikely, you can do serious harm to your OS via registry edits. I take no responsibility for any damage caused following this. This worked for someone on Rallyesim forums, I have not personally tried this.

    Open regedit.exe
    Click file -> export, change "export range" to all, and save it to your documents. This is your backup. If you need to restore from backup click import and locate the file.
    Click edit -> then find
    type in "oemdata"
    Keep clicking find next until you hit your device, I don't know what the name is for your wheel, but for example mine looks like this:
    [​IMG]
    Note: Be very sure you have selected your wheel, it's possible your driver has listed all compatible wheels in your registry. Mine shows both Logitech Driving Force, and the Logitech Driving Force GT, I only own the GT.
    Select OEMData, and then right click -> modify.
    enter in the new values (copy the old values down somewhere first, if this doesn't work, paste them back)
    Code:
    43 00 88 10 13 00 00 00

    click ok
    Close regedit,
    Try RBR, if it doesn't work restart your PC, try RBR again.
    If it still doesn't work, then re-enter the old values. (to ensure that the other games with which your wheel works still work.)

    If for some reason this buggers up your wheel for other games, uninstalling and reinstalling firmware and drivers should (probably) fix it.
     
  15. That was awesome instructions! You are the man.

    Now, I am a little confused because none of the VID folders list anything that looks like a porsche wheel, but one of them does list a g25.

    Under the OEM folder is:
    Sidewinderautodetect
    VID_0EB7&PID_0011 <---- this one has the G25 listed
    VID_0EB7&PID_0197
    VID_0EB7&PID_038E
    VID_0EB7&PID_1839

    The only time the computer has said I had a G25 connected was when I tried playing with the wheel in PS3 mode (suggested by someone to try to fix the ffb)

    EDIT: In case it was not suggested, the FFB issues were happening before I tried it in PS3 mode just the same.

    Thanks!
    Blaze
     
  16. Hey Warren, Remember me , with the grey out menu, and we went for a week trying to figure it out, and it came down to my native resolution not matching up with the ini, being 1024x 768? or was it 764? Anyway, I think you remember, and maybe this is help maybe not. Cant hurt, it's only typing on a keyboard.Just a thought.
     
    • Like Like x 1
  17. Michael Nelson

    Michael Nelson
    Premium Member

    Edit: Try Zebra's idea first, much easier to test than these ones. :p

    Strange, I wouldn't mess with any of the entries if I couldn't identify what it is though.

    Try searching "fanatec" or "porsche" or "gt2".

    If you can't locate it, then send an e-mail to Fanatec with details of your problem, and see if they are aware of it, and have any ideas for fixes.

    --

    Just did a quick search on Fanatec's being listed as G25, apparently that's what happens when you put it in PS3 mode. Quite odd.

    I guess then there's a few more things you could try.

    You could try downloading Logitech software and plugging your wheel in PS3 mode.

    Alternatively, open your device manager and if the G25 is listed under "Human Interface Devices" Right click on it -> properties -> driver -> uninstall.
    Unplug your wheel, reconnect it (not in ps3 mode) and make sure your Fanatec drivers register the wheel.

    --

    If that doesn't work then try posting here:
    http://f-wheel.com/forums/index.php?board=2.0
    It's a Fanatec support forum.

    (Ok, after searching on that forum, 2 more things you can try...)

    1:
    Disclaimer: Don't do registry edits if you don't feel comfortable with it, although unlikely, you can do serious harm to your OS via registry edits. I take no responsibility for any damage caused following this.
    (you may have already done this, you said something about the registry in your first post)


    2:
    Use the "116" driver, if you haven't tested that one.




    But really, if ti doesn't work after all that, e-mail Fanatec. :p
     
    • Like Like x 1

  18. I was hopeful about that one because I had lowered the res for fps reasons, but I changed it to the native res and still no luck.
     
    • Like Like x 1
  19. Darn, I was hoping we could get by with the simpliest of fixes, But that is just the thing, ....my native resolution on my PC made the menu dissapear....my native is 1364 x 768,(just a simple laptop) but to get out of what you are experinciecing, I had to change the resolution in RichardBurnsRallyini. to 1024x 768 .

    It was weird, and even the expert Warren was surprised.

    BTW, I am a complete noob, just try'n to help thru personal experience, With that said, I will back out, and let others with more knowledge help you. Best of luck.
     



  20. Okayyy... So, hour of head against the table-fun later, and here's where I'm at.

    I downloaded driver 116, did not fix the issue, but I left it on the wheel because it scrolls through the setting options a lot faster. :p

    I downloaded the logitech software and made progress! The force feedback menu was no longer grey and I could get into the FFB menu! However, the ffb test did nothing and there was still no ffb in game. I looked up how to fix this, (I remember seeing other people with this problem in the search for my own) and everyone said to do the registry tricks.
    I did that, but now the wheel centers itself upside down in PS3 mode and the FFB menu is gray again. xD

    Also, a interesting note, the code in the oem file was already the code you provided me with.

    So, I will probably uninstall the logitech software, and post on the f-wheel forums.
    If I still can't get it by monday I will shoot Fanatec a e-mail. ( I might hear back from them by next weekend ) :p

    Super big thanks to all the help you all offered me!
    Mike, like I said - you're the man.
     
    • Like Like x 1