1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

"Fingerprint Mismatch/Invalid Serial"

Discussion in 'Stock Car Extreme' started by Slade Mitchell, Oct 14, 2013.

  1. Hey all-

    I bought the game a few days ago, and played for about 8 hours before I was greeted with this screen when I try to start GSC:

    [​IMG]

    I contacted support, but haven't heard anything. When I try to re-enter my serial, it says my serial is invalid.

    Things I've tried:
    Reinstalling
    Clearing Registry, and reinstalling
    Installing demo, and activating with serial
    and tried the things listed here:
    http://www.racedepartment.com/forum/threads/game-stock-car-2012-faq-english.52944/

    None worked.


    Help?
    Thanks!
    ~Slade
     
  2. Justin Swan

    Justin Swan
    RD-DVLC

  3. Renato Simioni

    Renato Simioni
    Reiza Studios

    If you run into this issue, please download this file, and extract into the GSC2013 root folder, overwriting the originals.

    You´ll then need a Serial Number to correct the problem. Please email sales@reizastudios.com or PM here to get it.

    We will correct this bug for the release coming up.
     
    • Beer Beer x 1
  4. Hmm. I replaced the files, and added the new serial, but it has the same thing. Fingerprint mismatch, and invalid serial when I try to enter the new one as well. :/
     
  5. Renato Simioni

    Renato Simioni
    Reiza Studios

    You need a new Serial specific for fixing the program (though I assume you might have gotten it from support).

    This does not seem to fix it for everyone. We are working on getting this sorted with Gameshield ASAP - it should not take longer than a couple more days.
     
  6. Yup, they gave me a new serial, but it didnt work. Kind of a shame that I got to play it for no time at all, and now I get to wait for hopefully "just" a couple days... :(
     
  7. Issue solved by support.
     
    • Like Like x 1
  8. Hi, I am having this same issue as of today. What do I need to do? I have made contact via sales@reizastudios.com with my details.
     
  9. Same problem here.
    Can't play, invalid serial number.

    sales@reiza.... don't answer yet.
    Waiting for reply.

    Thanks.
     
  10. Kevin Hopkins

    Kevin Hopkins
    Premium Member

    I am having the same issue,have contacted Reiza and suggested i try i a few things(all of the above),none of which worked.Now i am hearing nothing from them even after a follow up email.....just a little bit annoyed.
     
  11. when I click on the file download link i get an error. This is VERY annoying, can someone from Reiza please at least respond. Emailed sales several times already with no response yet.
     
  12. Tomas de la Fuente

    Tomas de la Fuente
    Premium Member

  13. Tomas de la Fuente

    Tomas de la Fuente
    Premium Member

    Thank you Reiza for your quick answer!!!. :whistling:
     
  14. Tomas de la Fuente

    Tomas de la Fuente
    Premium Member

    Great, Renato has helped me and now the game is working fine, thank you very much!!!. ;)
     
  15. Same thing Here, Mismatch thing Messed with mine also......Im about to wright my own code just to get to work..lol.....Dad used to say Either fix it or I Will !
     
  16. All handled by Support
     
  17. Have now sent a tweet to @ReizaStudios - still no reply from any of my e-mails :(
     
  18. Start a conversation on here with reiza...That worked for me
     
  19. Same problem for me after bios and drivers update