1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FFB optimization

Discussion in 'Automobilista' started by Transyt, May 9, 2016.

  1. Hi, guys. I'm new to AMS. As you know, there is FFB center deadzone for G27. But there's a tool called LUT for Assetto Corsa that can change the FFB output curve to eliminate FFB dead zone in the center area. So I wonder if there's any similar tool or method to work on AMS?
  2. No.
  3. JoelGL

    Premium Member

    Not a tool, but perhaps like GSCE, you can try FFB steer force neutral function.
  4. Can you specify on this, please? What should I do?
  5. JoelGL

    Premium Member

    Sorry, it's in your control.ini under userdata. They suggest setting it to your whee's Min Force determined by wheelcheck.exe.
  6. Well, I found these in Documents\Automobilista\USERDATA\CONTROLLER:
    FFB steer force neutral range="0.04500"
    FFB steer force neutral function="0.00000"

    What should I do to eliminate FFB deadzone in the center? I tried put 0 in steer force neutral range and 1 in steer force neutral function, but nothing changed in the game.
  7. JoelGL

    Premium Member

    Not sure if if works fine with AMS, as that was suggested way back for GSCE. If it would work, a value of 1.0 is extreme (=100%). A value of around 0.18 (18%) is more like it for some G27's.
  8. After oodles of FFB fiddling across multiple sims I've come to the conclusion that most of this obsessive tweaking is just selling snake oil to yourself.

    AC's FFB didn't become any better to me with the LUT tool. I just have my wheel at 105% and set FFB power to avoid clipping and leave it at that.
  9. Well, at least LUT does eliminate the central FFB dead zone, and that's all I want. Anyway, I just need to get rid of the dead zone, if there is a proper way.
  10. afaik many g27 owners solved this by changing: FFB steer force neutral range="0.04500"
  11. I always thought those settings were there to add a FFB deadzone in order to avoild oscillations. It definitely sounds like it is based on the explanations:

    FFB steer force neutral range = Max distance from center "neutral force" location where forces are reduced to help avoid oscillation (0.0 to disable)

    FFB steer force neutral function = Function to apply near neutral force location, in order to tune out FFB "deadzone" but keeping oscillations in check: 0.0=original, 1.0=new

    So the first setting sounds like it's setting an area, starting from the centre of the wheel, to reduce FFB. Then, that reduced-FFB-area gets larger the larger the number it's set to. So, from the sounds of it, you'd want this set to 0.0 in order to disable it and have the most FFB come through since your wheel (certain Logitechs) already has a FFB reduced/dead zone.

    The second option sounds like it changes the "style"/way the first option works and therefore should be irrelevant if the first option is disable (set to 0.0).

    Do these settings even work if using RealFeel @ 100% mixing + Pure/Low FFB level?

    I'd follow that advice. Raise your wheel's control panel's FFB. It may help. Although, with my Logi G25, even raising it to 130% or 150% didn't make a difference because the FFB in the centre was essentially fully off but that was like 8 years ago so it may be different nowadays with all sorts of different firmwares and such.
    Last edited: May 11, 2016
  12. Well, I found this one: http://steamcommunity.com/app/431600/discussions/0/405694115203461899/

    But I can't get a desired result like people in the link did. Dead zone is still there. I It maybe helps when car stops, but when it drives, dead zone goes back. God I wish AMS will one day support LUT calibration.
  13. OK, so the person in that link/post seems to be agreeing with me regarding "steer force neutral range", and it sounds like "steer force neutral function" is basically a minimum FFB setting (sweet) but it sounds like this only works at/near centre rather than all the time because it says that it gets applied "near neutral force location".

    So make sure range is set to 0.0 and then set function to 0.2 (20%) just to test.

    Also, make sure you're editing the correct file. This can be confusing for newer users since there is a controller.ini file in the player folder + there are a bunch of other controller files, including your saved ones, in your controller folder, and there may be other controller files in some other weird places (I think Reiza should clean up the files/folders a bit, there are duplicates of some things while only one of them actually work, like the game's config file which took me a week to figure out I was editing the wrong one). If you edit the controller.ini in your player folder then make sure to not load a controller preset while in-game since you want to use the controller.ini file (it'll have all the settings of your last used controller settings anyways, besides the settings which you just updated, so don't worry). Or, if you do change one of your actual saved controller ini files in the controller folder then make sure to select and load that file once you're in the game.
    Last edited: May 11, 2016
    • Agree Agree x 1
  14. Yeah, so LUT support seems the only way to totally eliminate central dead zone. Any idea how I can propose this to official?
  15. It sounds like setting range to 0.0 and setting function to a # (eg. 0.05 for 5%, 0.2 for 20%) should do the trick of eliminating any game-induced FFB center deadzone (range) and increasing FFB forces at/near centre (function).
    Last edited: May 11, 2016
  16. No, I tried, but dead zone is still there. I don't know if it is just me.
  17. I doubt it's you.

    Maybe these FFB settings don't work when FFB is set to Pure/Low. Try this: in-game, set FFB to full (or whatever it's now called, "180Hz + effects" or whatever). Actually, while you're at it, disabe RealFeel too; to.do this, go on track and then press the plugin enable/disable button. Use a big number for function, like 0.5 (50%) and make sure range is set to 0.0.

    Do you have experience with messing with the controller files in these games? I just want to make sure you're editing the correct controller fil3.
  18. its controller.ini. And it's alright. Maybe I should delete these files and redownload them from steam to see if it is ok.