1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Fanatec wheel bricked after latest firmware update

Discussion in 'Sim Racing Hardware' started by mycarlooksfast, May 12, 2016.

  1. mycarlooksfast

    mycarlooksfast
    Premium Member

    Help! Having serious problems with my almost brand new Fanatec CSW. Was prompted to update the firmware last night, so I did, and when it restarts afterwards and goes to calibrate, it gets about 45 degrees from finishing, stops and shuts the wheel off, disconnecting it from the PC. The tuning menu works and I can fiddle with the settings like the wheel is on, but it isn't: the fans aren't running, the power LCD isn't on, and the PC doesn't see it. I'm also getting resistance in the wheel that goes away when power is removed, so the wheel thinks it's on, but it's not.

    I've uninstalled and reinstalled the drivers, reinstalled the firmware multiple times, with no luck. It was working just fine before the firmware update, now it's bricked and worthless.

    Anyone else having issues with the new firmware? Any ideas or help before I contact Fanatec?
     
  2. mycarlooksfast

    mycarlooksfast
    Premium Member

    Opened up a support ticket with Fanatec anyway. Wheel is only a few months old, I paid a lot of money for it, and it was working perfectly hours before this unnecessary firmware update, so this is absolutely unacceptable. Hopefully their response is quick and helpful getting this back up and running again. Not happy. :mad:

    Here's a video of the problem:
     
    • Love Love x 1
  3. James Robertson

    James Robertson
    Premium Member

    You could maybe try disabling all anti virus / firewall software and try again. It's probably not the cause but it's worth a try.
     
    • Like Like x 1
  4. mycarlooksfast

    mycarlooksfast
    Premium Member

    I don't run anti-virus or firewall software, so that can't be the issue. I appreciate the suggestion and trying to help, James. Thanks for the response.

    Got an email from Fanatec support this morning with unreleased firmware to try out but unfortunately, same result. Awaiting their reply with another idea, I feared someday these useless and unwanted firmware updates would f my wheel up...and here we are. Pretty ticked about this whole situation....
     
  5. PicoBp

    PicoBp
    #26 | HSRC - Banzaaaiii Touring Car Crew Premium Member

    Are you using an onboard or front panel USB port? USB2 or USB3? The latter is known to cause issues with most wheels. Just another guess.
     
    • Like Like x 1
  6. mycarlooksfast

    mycarlooksfast
    Premium Member

    I have it plugged into a USB hub that's connected to a rear USB 2.0 port. Nothing changed in the connection between when it was working and now, so that can't be the problem either. Just out of curiosity, I did try connecting to a few different ports both front and rear including a USB 3.0, but same result. :(
     
  7. Alex Townsend

    Alex Townsend
    Premium Member

    Have you tried rolling back to the old drivers and firmware?

    I had an issue with a firmware update once and took the wheel back to a really old firmware first and then updated to a known / good firmware and driver.
     
    • Like Like x 1
  8. mycarlooksfast

    mycarlooksfast
    Premium Member

    I thought about that, but was unable to find older driver versions on either the Fanatec website or through a google search. Do you know where to get these older drivers/firmware?
     
  9. Alex Townsend

    Alex Townsend
    Premium Member

    • Like Like x 1
  10. mycarlooksfast

    mycarlooksfast
    Premium Member

    Thanks, I totally missed that page! Firmware V037 won't load up on the CSW 2, so I installed the earliest drivers (v219) and firmware I could, reflashed and same problem. Tried another driver (v226 beta), no change. So I'm beginning to suspect the latest firmware indeed bricked the wheel and it needs replaced.

    Still waiting for a response from Fanatec but them being in Germany and me in the states, I suspect this communication and resolution is going to be glacially slow. Good thing I held onto my trusty G27.
     
  11. Alex Townsend

    Alex Townsend
    Premium Member

    They have Fanatec in the US though right? Or did you purchase the wheel from Europe?

    Hope you get it sorted quickly. I know only too well that feeling of a bricked wheel.... not nice and touch wood I've not had to go through it yet with my trusty V1
     
    • Like Like x 1
  12. mycarlooksfast

    mycarlooksfast
    Premium Member

    I purchased the wheel from the Fanatec US website, my guess is support is all in Europe. Still no response from my reply yesterday morning. If they don't have any new ideas or firmware to try next week, I'm going to push to start the RMA process and have them ship me a new wheel. It's less than 4 months old and they are solely responsible for the worthless condition its in now, so I want it resolved with a sense of urgency.

    Thanks for the help and support Alex. I can live without sim racing for a bit, but to be in limbo while support has no clue how to proceed is a bit disconcerting. I hope your wheel stays trouble free.
     
  13. Alex Townsend

    Alex Townsend
    Premium Member

    Oh yes. May be right there about the support.
    Fingers crossed that Fanatec get themselves together and sort your problem out asap. The costs involved for the end user really should warrant immediate support.
    Unless there are unusually high queries due to defective drivers messing up everyone's wheels...
    I hope mine stays trouble free but you never know when some of these components have had enough.
    I've just bought myself 2 Spare motors, 4 load cells and wiring just in case so I can at least prolong the lifespan of my setup a little longer.
     
    • Agree Agree x 1
  14. mycarlooksfast

    mycarlooksfast
    Premium Member

    Seems I'm an isolated case having this issue since no other fanatec user has chimed in with similar problems. Can't get help here, can't get help from fanatec. This situation is unreal. :mad:

    Edit: Response from support this morning, RMA initiated, base sent in this afternoon.
     
    Last edited: May 17, 2016
  15. James Robertson

    James Robertson
    Premium Member

    According to a google search today is a national holiday in Germany. I have owned multiple fanatec wheels and have always found their customer support excellent. They will probably get back to you tomorrow when they are back at work.
     
    • Like Like x 1
  16. mycarlooksfast

    mycarlooksfast
    Premium Member

    Thanks for the info. If that's the case, they get a little slack. :whistling:
     
    Last edited: May 17, 2016
  17. James Robertson

    James Robertson
    Premium Member

    Any updates?
     
    • Like Like x 1
  18. mycarlooksfast

    mycarlooksfast
    Premium Member

    Yes. Support got back to me yesterday morning, initiated RMA immediately as requested, and the defective base is on it's way to Fanatec's repair facility in California. They said about a week turnaround for repairs and it should be on its way back to me.

    I have a much more positive impression of their support since yesterday as they've been quick in responding to emails and informative on the warranty repair process. However, until I receive the wheel base back in working order and reimbursement for shipping it back to them, I don't want to get premature with praise. And it still doesn't change the fact that this whole situation is a massive headache that never should have happened in the first place.
     
  19. mycarlooksfast

    mycarlooksfast
    Premium Member

    Received the base back from repair on Friday and it works as it should. Great to be back on the virtual track!

    Fanatec support was wonderful through the whole ordeal. Quick responses to multiple emails sent back and forth between me in the US and support in Germany. Wheel base was at their repair facility for a bit over two weeks. Shipping back and forth was taken care of. All things said, I had less than a month of downtime. Very happy with the outcome...the hardest part was being patient.

    It would be nice to know why or what caused the fault to begin with and I doubt they'll disclose that to me. Either way, I will be extremely apprehensive about firmware updates in the future.
     
    • Love Love x 1
  20. Alex Townsend

    Alex Townsend
    Premium Member

    Glad to hear it all got sorted. Ive always had positive outcomes with Fanatec
     
    • Like Like x 1