1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC Fanatec driver issue ?

Discussion in 'Assetto Corsa' started by NaokiSpeed7, Aug 1, 2015.

  1. Hi all
    I don't know if the problem is in the driver or is in the game but, using drivers 219, 222 and 223 only in Assetto Corsa the rev lights in my CSW v2 rim not work, also is not work in my siminstruments dash and android app dash, have someone with the same issue and find a solution ?
    Thanks in advance

  2. Sniper

    Premium Member

    I have the same issue, I rolled back to 205 drivers:(
  3. Thanks for your reply ! Unfortunately i can't back to driver 205 because it's not recognize my CSP V3.
  4. Sniper

    Premium Member

    Ah bugger, these drivers broke my HUD app as well, no rpm lights. Some people have said to remove fanaleds and reinstall it but that did not work for me but I have a v1
  5. Are there drivers 223?
  6. Sniper

    Premium Member

    latest driver on their site is 219 for me, where do you se 223?
  7. Tobbe Bergman

    Tobbe Bergman
    @ Simberia @Simberia

    I really wish that Fanatec made their own software for their LED display instead of relying on 3:rd party.

    Fanaleds seems to have a life of it's own and are riddled with bugs.
    • Like Like x 1
  8. Robin

    Premium Member

    There is no 223 driver.

    There is a 222 driver in beta which you can snatch from Fanatec's Blog.
    They are always slow with updating the product pages and some beta drivers have been listed in the products page, some have not.
    But for now grab the drivers from their blog.

  9. Sorry to be off topic but hopefully you can provide us a bit of a review of your CSP V3 :)
    • Like Like x 1
  10. Sniper

    Premium Member

    You guys must be luckier than me because I have tried all drivers and 205 is the only driver that gives me rev lights on my v1 wheel and on my android app HUD dash. Any other driver breaks this and this is now on a clean windows 10 install. Tried reinstalling fanaleds etc multiple times. So frustrating
  11. Hi
    Fanatec driver 226 available in the download section, Fanaleds not work never more but you can use SLI MAX MANAGER III from EKSIMRacing.com for your Fanatec rim, also all HUD app works now.
  12. Hi
    Fanatec driver 226 available in the download section, Fanaleds not work never more but you can use SLI MAX MANAGER III from EKSIMRacing.com for your Fanatec rim, also all HUD app works now.
  13. Tobbe Bergman

    Tobbe Bergman
    @ Simberia @Simberia

  14. Using Fanaleds 2.3d with 226, works fine. For those having issues with Fanaleds, uninstall after new driver upgrade.

    Also take into account, Fanatec proper driver removal....unplug controller, uninstall, reboot, install, plug in, research Firmware upgrade (usually read through hype, most firmware issues I found relate to Pcars on PS4 and people not doing things correctly like not even calibrating wheel after firmware upgrade), do firmware upgrade if necessary...usually good idea as they communicate with driver better. Don't ask me that's just how API layers talk to one another.

    Then after your driver's are settled, install Fanaleds (if using this), then hop in a car, investivgate RPM's in relation to power band and when you want to shift and what group of lights you want to light up. Then go back to App, go to Hardware and "let it learn your hardware". This is an important step, as it's illustrated in their V2 video manual. Waht's also important I noticed is mapping independent RPM metering (lights) based on the car. For instance, a Porsche or Ferrari that likes to Rev in the 6-8K RPM range is different from say a Viper with a V10 torquey' motor that you barely use anything above 5k RPM's.

    Also RTFM when things don't work properly :thumbsup:.
    This works with base firmware 65, 110, and later FYI. Fully tested on Windows 10 X64 Pro as well this weekend with many hours of enjoyment this weekend.
  15. how are different cars' revs different for setting up shift lights? I thought a percentage from redline should be good for almost all cars?
  16. thats interesting because many other people wrote this:
    and that
    https://www.fanatec.com/forum/discussion/164/fanatec-driver-222-beta-released-windows10/p9 (search for Fanaleds on the site)
    So there must be another difference between your and our settings. If we find out everyone having this problem will be very happy.
  17. Tobbe Bergman

    Tobbe Bergman
    @ Simberia @Simberia

    I wish that Fanatec could make their own drivers for their REV & Gear lights.

    The Fanaleds seems overly complicated and is riddled with bugs and problems.
  18. Sniper

    Premium Member

    I use HUD Dash and with any driver above 2.05 I get no rev lights on that program:( that sucks