1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fanatec CSW V2 - unplayable

Discussion in 'F1 2015 - The Game' started by BJ4DESIGN, Jul 31, 2016.

  1. Hey all,

    So this has been happening for a solid 8 months now and I cannot find a result anywhere online. I gave up a while ago and just played Project Cars and iRacing instead.
    With F1 2016 coming soon, I thought I would have another try at getting this to work before I waste any money on the new version of the game.

    What happens is that as soon as I start a session, with no input from me the game turns full lock left and full throttle stuck on. So 100% unplayable.

    I have tried setting it as Fanatec CSW V2 default settings.
    I have tried setting it as a Direct Drive wheel.
    I have tried setting it as a custom controller.

    Have also tried re-mapping each axis and button on each of those settings.

    For my wheel base I have tried setting SEN to 360, 900, AUT and 400 (which had worked with the 2014 version of the game).

    So does anybody have any ideas at all on how to get it working?
    So far have played less than 6 hours on the game according to Steam, which is a pretty big waste of $80AUD when it first came out :(
     
  2. Is your V2 up to date ? If so try to select CSW V2 plus the steering wheel that you are using like F1 wheel or BMW ... . Don't change anything don't remap .... and give it a try .
     
  3. I try to keep my drivers and firmware up to date as much as possible.
    Just reflashed my firmware on the base and tried full default settings and still no good.

    No input from me and the game just turns full lock left and full throttle :(
     
  4. Have you tried to 'verify integrity of game cache ' for F1 2015 ?
     
  5. Hi bporion, thank you for the suggestion.
    I gave this a try and was able to complete the verifying of the game cache with no errors.

    Game still has not change in behavior, just goes full lock steering left and full throttle with no inputs.
    No idea how to fix it and feeling like just giving up on it.
     
  6. Chili P

    Chili P
    Premium Member

    Hi, I dont have Fanatec gear but if you have fanatec pedals have you tried connecting them separately through usb instead of through the wheel? Im sure that Ive read that this is possible somewhere and it might be worth a shot.
     
  7. If all of that dosent work wait and get F1 2016 in 2 weeks if you don't like it get a refund but remember not to play more then 2 hours .
     
  8. I bought this on CD as the limited edition pack when it first came out so not hope of a refund.

    Do you think it would be worth the old uninstall / reinstall to see if it works?
     
  9. You got nothing too loose ! And after reinstall do the verify integrity ... choose your wheel and don't edit anything . I know you can't get your money back on f1 2015 , I was talking about 2016 .
     
  10. Finally got a chance to do an uninstall and re-install of the game.
    Removed local content via Steam and re-installed using the CD and then re-downloaded the 9.9GB patch.

    Somehow it retained all of the in game settings (screen resolution, FFB sliders, control settings, etc), weird??
    Same result, full lock left and full throttle with no controller inputs = crash into the wall and do burnouts.

    Thanks to those who had helpful suggestions, however I guess this game is a lost cause for me now. Not that fussed as I have iRacing, ProjectCars and AssettoCorsa to use instead.
    I will keep an eye out for reviews and forum discussion on F1 2016 to see if anyone has controller dramas before purchasing. If it doesn't work after purchase via Steam I will request a refund instead of persisting like I did with F1 2015.
     
    • Like Like x 1
  11. So after watching Inside Sim Racing's day one review of F1 2016, I had a thought on another thing I could try.
    They discussed 2016 version now being multiple device compatible.
    When I had been starting F1 2015 I would get a warning saying DSD button box and Fanatec USB Handbrake not supported. I figured, "so what, they just wont work".

    So after watching the new game review. I thought I should try unplugging both of those devices and restarting the game.
    Turns out, they were interfering with the CSW V2 and my pedals. Game now works OK.
     
  12. Great ! Now get F1 2016 its a very good game !