1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

F1 2015 Thrustmaster GPX Lightback settings

Discussion in 'F1 2015 - The Game' started by SAEVARM3, Jul 10, 2015.

  1. Hello, the day has finally come ... F1 2015 is out but I´m having some issues with my controller on it. ( Thrustmaster GPX Lightback Xbox 360 )

    It says, Press B to Back but that doesn´t back, it just goes into the game like I pressed A ... but if I press X it backs for some reason... I´ve been in Controller setups trying to fix this **** but nothing seems to be working.

    Anyone out here using Xbox Controller who has some weird bugs on it?

    Peace and enjoy F1 2015 ! :D
     
    Last edited: Jul 10, 2015
  2. So I had this issue with my Rock Candy Xbox 360 controller. It just isn't compatible even though it is a Xbox 360 controller. I switched to my official Xbox One controller and it works fine.
     
  3. Well, I just have to hope this will be fixed ... Thrustmaster GPX XBOX Controller has never been a problem in any game (played all the F1 games and more with it)
     
  4. I made a video showing the car on the straights ... really feels like the game just doesn´t support this controller for some reason ( all the other games have supported it )

    Controller: Thrustmaster GPX Lightback Xbox 360
    Video:


    PS: I´m not doing the weaving by myself, I´m trying to keep it straight but all it does is twitch and takes weird turns .... atm I can´t play the game which is a shame :(
     
  5. Exactly my problem :cry:
     
  6. Okey, good to know I´m not alone but not so good since this "bug" is not allowing me and others to play atm :(

    I did a whole lap in Bahrain just to showcase how shitty this is ... I´m fighting the car the whole lap haha

     
    Last edited: Jul 10, 2015
  7. From Walter

    I send a mail to Thrustmaster about this problem. I have the same problem as......

    [​IMG]
    SAEVARM3 see video above Bahrain. I have GamePad GPX LightBack Ferrari F1 Edition.
    GPX.jpg
     
  8. What do you think Thrustmaster can do ? ... this must be a faulty coding within the game right?
     
  9. Alright you have a point! SAEVARM3. So we have to wait for a fix for it? What do you think about this problem? Than we have to write Codemasters for this problem, or you already did it? Please let me know about the progress. Thanks for answering!
     
  10. My english isn´t all that good so I haven´t written any letters to codemasters and I highly doubt that will do anything....
    I´m just hoping they are as we speak working on a patch for this controller issue, haven´t been able to play the game since the release day and it sucks :(
     
  11. Yes SAEVARM3 its frustrating if there is an nice game and you can't play it . I wrote a letter to codemaster for this problem. So i hope they will fix it. Till now we have to wait. I hope not for long. If i know more....i let knowing on this forum. Your english is'nt bad...i understand you are writing.
    This is what i wrote to Codemasters:

    Dear Codemasters,
    Some people have the same problem with some GamePads. I refer to RaceDepartment so you can read and see video's about the problem. Hope you can fix it by making a bugfix for my GamePad GPX LightBack Ferrari F1 . Thanks!

    Here the link to Racedepartment:
    http://www.racedepartment.com/threads/f1-2015-thrustmaster-gpx-lightback-settings.108308/
     
    • Like Like x 1
  12. Awesome, really hoping they will work this out...

    But atm, I actually found a temp fix for this bug we have over on codemasters forums ... it´s not 100% but now I can drive and enjoy the game! :)

    -----

    Open file "action_map_preset_win.xml" the path is "C:/ProgramFiles/Steam/steamapps/common/F1 2015/actionmaps".
    Then you need to search "xi_Preset1" (or "xi_Preset2" if you use preset 2), few lines below you have "Steer Left" and "Steer Right" so just change value of "deadZone". In my case I set them to 0.0 and now I can actually PLAY!
     
  13. Good Work man!!! Thanks! Yes its much better but not 100% you said. We have to wait for the real solution, but for now enjoy playing i would say. Thanks for answering!