1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

F1 2014 SweetFX ... Please Someone Help Me

Discussion in 'F1 2014 - The Game' started by mmpaw37, Oct 18, 2014.

  1. Right, where to start...
    Firstly, I have been using SweetFX 1.4.1 for a very long time now for games such as F1 2012, F1 2013, rFactor and so on, and I have never had any issues with it.

    However, since I have had F1 2014 and TRIED to get it working in 2014, now it doesn't work at all for the rest of them!.
    I'm not to bothered now about the rest but, please can someone send me their SweetFX folder with settings, preferably for F1 2014. I seem to be doing everything right as before but for some unknown reason, it just won't work in F1 2014???

    Hope someone can help me, I am literally 5mins away from smashing my gaming PC to bits!!!
     
  2. Mine says "directx 10 or 11 support required" :(
     
  3. Alain Becker

    Alain Becker
    Premium Member

    Are you using Windows 8?
     
    • Love Love x 1
  4. 8.1 yes
     
    • Love Love x 1
  5. Alain Becker

    Alain Becker
    Premium Member

  6. I have been using SweetFX with Win8.1 Pro, and I've never had this issue before.

    By the way, I am using RadeonPro because as you may be aware, SweetFX doesn't work without it on AMD cards. But like I said, I have been using it fine in both F1 2012/13 without issues...and rFactor etc.

    Anyway, the kind members of RD have given me some to try so when I get the chance, I will see if those work.
     
  7. It's not my file, I just pointed out where I got it from (ages ago), you'll have to ask @ALKMNDZA as he's the creator of the settings.

    For the default SweetFX files go to http://sfx.thelazy.net/downloads/ or http://www.guru3d.com/files-details/sweetfx-shader-suite-download.html
    And then maybe download seperate settings (to your liking) from http://sfx.thelazy.net/games/game/712/ or alternatively tinker with the settings yourself.
     
  8. Just to let you guys know, I have managed to get SweetFX working by just disabling the 64bit support option in the settings...working like a dream now!!!

    Thanks everyone for support! ;)
     
  9. I gave up trying to get sweetfx to work on 2014. Worked fine on all previous games witht the exact same installation but not this. :thumbsdown:
     
  10. How mate? How do you disable the 64 bit support?
     
  11. Could U describe better? where can disable the 64bit support option?
     
  12. Its on the 'General' tab in the settings. There's multiple check boxes enabling different items, but you'll see it.
     
  13. All I can say is, best thing to do with SweetFX is, place the folder somewhere on your PC, but not in the F1 2014 directory.
    I am using RadeonPRO, obviously because with AMD cards, the game won't start without it, and of course you can't use SweetFX. All I have done, is place the SweetFX folder in my mods folder, created a profile in Radeonpro, and then just import SweetFX settings from the folder - Apply them and click Start in the menu after right clicking on the profile in RadeonPro.

    I couldn't get it to work at first, but then I just did a 'trial and error' stage, where the disabling 64bit support came into it, now it works as it should.

    I don't really know what I can tell you in regards to the DirectX issue, if I remember rightly, I had an issue once where there was a file included with SweetFX(something like dxdigi or something like that), which was causing an issue, although that was when I was trying to use SweetFX without RadeonPro.

    I'm sorry I can't be of more help with your issue. What gfx card you using by the way?