• This Website Is Not For Sale
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

F1 2014 - Logitech G27 Settings

Discussion in 'F1 2014 - The Game' started by vbabiy, Oct 28, 2014.

  1. vbabiy


    I am wondering what people do for fuel/tire/break management on the g27, do you stick with the pov switch? do you map buttons?

    I have found the pov to be pretty tricky to use while driving, it could also be I need more practice :D.
  2. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

  3. Hi.
    Can someone help me configure G27 settings for this game. Game is broken.

    Impossible to make turns in any corner slow or fast. Off/on throttle you need like 900 degrees of g27 to make corner even though its locked to 540. I tried going down to 330 degrees of rotation does nothing. The wheel in game and steering wheel is not 1:1 ratio.

    Also coming out of turns no matter how much or little throttle you apply car just slides and some magic traction control saves it.

    With xbox controller with all assists game is actually playable can do normal lap times but with wheel its impossible 10-12 seconds slower then ai.

    In the logitech profiler I have
    overall ffb strength 100%
    damper 0%
    spring 0%
    enable centering spring checked with slider at 0%
    degrees of rotation 540

    allow game to adjust settings checked

    in F1 2014.
    all assists off.

    vsync on
    advanced settings all at 0
    FFB environment 50%
    FFB wheel weight 50%
    FFB feedback strength 50%
    override input device steering wheel
  4. I use the same settings someone on here recommended as supposedly very pure last year. I expect you will find them fairly extreme compared to what you're running (I did at first), especially the lack of centering spring. But I have no issues at all on turn-in. The car is very light and nippy.

    Overall FFB Strength: 50%
    Spring Effect: 0%
    Damper Effect: 0%
    Untick enable centering spring in FFB games.
    Degrees of Rotation: 316

    In game I run all assists off, V-sync OFF, advanced settings at 0, except for a touch of steering deadzone and 5% saturation (personal taste).

    FFB environment: 10%
    FFB strength: 100%
    FFB wheel weight: 50%
  5. I map the directions down, right and up to buttons on the wheel so I can adjust the fuel mix while driving. I found reaching over to the shifter while driving was too hard.
  6. I see they've merged these G27 threads.

    Anyway, I use a software program called GlovePie that someone recommended years ago on here that allows you to speak an instruction (say "mix three) and it does all of it automatically for you. It's brilliant.
    • Like Like x 1

  7. What wheel are you using?

    Your setting sadly do nothing.

    The steering wheel in game doesn't turn as much as G27 steering wheel does.
    With vsync or no vsync same thing.

    Only way to make the game steering inputs match my G27 inputs is having steering wheel saturation at 60-65%. Then its possible to have 1:1 ratio.

    At 60-65% wheel is so sensitive and really hard to drive.

    Can't believe Codemasters releases something that can't even work properly out of box.

    Whats funny is even with every single assist off it feels there is some magic assists on.

    Take hairpin at normal speed real wheel turned 45 degrees meanwhile game steering wheel is making small adjustments (could be graphical effect only) when you aren't lol
  8. What are your other wheel settings? I'm pretty sure I have deadzone, linearity and saturation all at 0. With my degrees of rotation set somewhere around 300 in the Logitech profiler my wheel matches what's on the screen exactly and it feels fine, including in hairpins.
  9. My main issue is getting my wheel rotation to match game wheel.
    Its impossible to drive when it literally requires lock to lock to make hairpin
    only why I add steering wheel saturation at 60-65% it works.

    Btw I play other games assetto corsa, rf2 etc and have zero problems with G27. Works perfectly there.

    F1 2014 profile for logitech.

    overall ffb strength 100%
    damper 0%
    spring 0%
    enable centering spring unchecked with slider at 0%
    degrees of rotation 316

    allow game to adjust settings checked

    in F1 2014.
    all assists off.

    vsync on or off does nothing.
    advanced settings all at 0 expect for steering wheel saturation at 60%

    FFB environment 50%
    FFB wheel weight 50%
    FFB feedback strength 50%
    override input device steering wheel

    if I leave steering wheel saturation at 0% it requires literately 900 degree G27 turn to make hairpins lol.
  10. I'm wondering if your profile is not activating so your degrees of rotation is way too high. When you turn the wheel in the menus do you feel it hitting the stoppers at around 150 degrees in either direction? Maybe try overriding the profiles and set your global profile to 316 (and set the saturation back to 0).
  11. I'm using a Logitech G27. With my settings I have no issues on turn-in, and the on-screen wheel more or less matches my own inputs.

    Something sounds very wrong for you, as Andrew says.
  12. Hey Vitaly. It's your "buddy" Felonious Monk! LOL! Anyway I use the top two buttons on the wheel on each side. So the top left button is up, the middle left button is down, the top right button on the wheel is left, and the middle right button on the wheel is right. It takes a bit of practice but I'm getting faster at selecting options. I use the bottom right button for DRS. Not having KERS this year makes things a lot easier. Anyway don't take that first race as how I race man.. I sucked on that one.. lot of stuff went wrong. I'll hit you up when I see you on Steam to race again. Later dudes and dudettes!
  13. BTW for the guy with the wheel problems.. delete your F1 Profile in Logitech profiler. When I activated mine it screwed up F1 2014 for me. Just run default Global settings in the profiler and with saturation at like 13 - 15, and linearity around 2 -3 in game . Game works perfect for me at those settings. Try it out. Like I said as soon as I started fiddling with the Logitech Profiler it was like the wheel was almost unresponsive. Really screwed up a few races for me. Good luck!
  14. ^^^^^
    yeah just tried it, working finally.

    in the logitech profile for f1 2014 I unchecked
    allow game to adjust settings and finally wheel turns 1:1 game and real one with advanced settings all off.

    now my next question is how do I slow down the steering wheel response rate a bit.
    at 0% everything in advanced menu steering is a bit fast.
  15. I think you may just have to get used to it. I'm not sure if you've played a lot of F1 games previously, but when I first started with F1 2012 I had to get really used to the speed. F1 cars are really fast.
    • Agree Agree x 1
  16. My last year's G27 mod seems to be working (at least for me). It binds the gears on gear stick to engine modes + tyres. With the mod (or actually config-file for Logitech profiler) you can quite easily bind the buttons too to e.g. brake modes. True especially this year, as there is no KERS button needed. See http://www.racedepartment.com/downloads/logitech-g27-modification.1090/

    Edit: I created version for F1 2014, see http://www.racedepartment.com/downloads/logitech-g27-modification-for-f1-2014.4130/

    Last edited: Nov 11, 2014
  17. Here we go again - G27 settings are useless on default in F1 2014. I like to feel the wheel into the corners, and know if Im on the kerbs/gravel etc.
    I've tried all on here and to reduce the profiler effects to 50% means you get no feel whatsover... so heres my effort for what its worth...

    profiler - effects 100%
    others - 0
    tick the spring and use 20- 25%
    315 degrees rotation
    tick allow game to adjust

    in game settings
    FFB 50/80/70
    Seven numbers from top 0,25,0,0,4,0,2

    This feels good but a bit loose on the straights, still I can manage that...
  18. Hi guys I need some help with my G27.
    This may sound strange but here goes.

    Iv recently upgraded my tv to a Samsung LED smart TV. Loaded up f1 2014 and as soon as I hit the track my wheel felt realy bad. Checked my setting and they were the same as normal, steering Linerty etc were all on zero. The input I make to the wheel matches the car wheel but the car reacts a lot slower. The brakes feel bad to and just don't react quick enough.
    I plugged my old tv back up and it worked as it always did, realy well.
    Anyone had or know of this issue and also can anybody help

  19. is tv at gamemode?i can change tv into gamemode....i have also led samsung 42" ps3 and g27....i have another problem...my wheel to fast sometimes,quali is awesome at race first stint survaivol..
    all 0% 30 100 50
    menu/system/basic....and you should find that ther
    Last edited: Dec 1, 2014
  20. Cheers Indrek, I will check to see if it has any different modes, Andy Goodwin suggested this to so maybe it could be just a mode setting so will look tonight.