1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

F1 2010.....One day she runs, the next day she doesnt !!

Discussion in 'F1 2010 - The Game' started by Jason Cross, Dec 26, 2010.

  1. People,
    If someone can help here you are an absolute legend. I am currently in S1 of 2010 (presently at Hockenheim), and about to start race day. Left qualifying last night (P2 on grid) and when started up the machine today, low and behold it will not load (steam game !). I get the grey box "preparing to launch F1 2010" and then nothing.......simply heads back into my desktop..

    It has me completely baffled and I have tried to peruse through a number of threads on here to attempt to resolve the problem.

    Could use the help people if anyone has heard of anything similar or has encountered a similar issue.

    Win 7 Pro 64bit
    ATI 5850 x 2 (crossfire)
    I7 Core 930

  2. What have you added since last bootup of f1?

    What is the exact error code?

    im guessing your running admin as it was working last night.
  3. I get that a lot. The grey box comes up and then nothing happens? I just keep trying and it works eventually.
  4. thanks for the prompt feedback gents, much appreciated.

    Jase, in response to your queries, I actually dont get an error code as such. When launching the game from Steam, it simply fires up the grey dialog box "preparing to launch f1 2010" and then that goes away, the blue timer kicks in for a second or two, and then - nothing. Simply returns me back to the desktop. No error or anything.
    I am however wondering if the graphics card update to ATI catalyst 10.12 has anything to do with it, because the machine in general has encountered some stability issues since downloading the update which was around the same time as this problem started. Having said that I have rolled back to the previous catalyst install with no joy, and even restored windows 7 to a previous date to see if this helped, but again not joy either.

    If anyone could give me some pointers (really dont want to uninstall and reinstall F1 2010 if I can help it) that would be appreciated. Just want to get the damn thing fixed, and not having an error message is really pissing me off !! (at least with an error message you have some clue as to the problem)

    Cheer guys, appreciate any further feedback.
  5. Can you attach your windows admin log and dx diag?

    the admin log should have a report of any crashes, although I have had your problem before with steam....and could never fix it and after a while it worked again.
  6. thanks for that Jase, and a quick update for you.........still not resolved is short answer however I feel this issue could be more related to pc stability issues rather than the game simply not starting. The following has occured since last post:

    1. Reinstall F1 2010 - no change and did not start
    2. Run as administrator - no change and did not start
    3. Blue screen crashes - Fault is random
    4. Lock up trying to play Grid - Game freeze at lobby

    Out of ideas mate, and like you stated in a previous post, might just wait it out and see if comes good after a few days (perhaps my pc has a slight cold !). Neverless, if you have any other suggestions, I am all ears !!

  7. jcross069, see if this works.

    1. go to START
    2. RUN type cmd
    3. type cd/
    4. go to the directory of the game (c:\program files\Steam\steamapps\common\f1 2010).
    5. type f1_2010.exe

  8. thanks for the trial suggestion Thunder7896, however no luck I am afraid. Get the same activity (ie post from 2 days ago) as before. Nothing happens.

    1. Checked all drivers and are current
    2. Ran memtest with some errors showing (could it be ??)
    3. BSOD "Memory Management" error (somehow linked to F1 not loading ??)

    Any suggestions to fix would be welcome (and please dont suggest for a complete PC reinstall !)

  9. Try running steam then right on the game in the steam window properties>>verify integrity of game cache.

    It will return game files to default but wont delete save games as they are in documents.

    Also if the game runs it will need to download the patch again.

    Also try running the game with internet disabled.
  10. i had that problem with dirt 2 and steam, running the exe directly and not through steam seemed to fix it.
  11. Problem Solved !! (although I dont know how.........)


    Well after installing and reinstalling steam (3 times), GFWL (2 times), and F1 2010 (2 times - via download i might add), the game now starts !! (go figure). I have absolutely no reason as to why, nor can explain it (a pc gremlin exists here I think). Anyway I have fully tested the game (pre patch) and am now about to download the patch and see what happens. Will keep you all posted.

    Thanks all for the help and suggestions to date, much appreciated and thanks again.
  12. Good luck :D and Happy New Year !
  13. Cheers David.

    Well the post patch worked, although the game now suffers with the random "F1 2010 executable stopped working" ......Gotta love game stability!.

    Will read through forums re this as I know many others have suffered.....(at least the game actually starts now)

    Cheers all and happy new year
  14. Update:
    This may help others who are searching for possible solutions to solve the "F1 2010 executable stopped working" bug, although I should mention I also was getting a BSOD Win 7 crash in parallel indicating computer instability.
    Anyway, I fixed both issues simply by running "memtest" on the PC, idfentifying a faulty ram stick and then subsequently installing a complete new set of ram(3x 2GB). After this I checked both clock frequencies and voltage in BIOS to ensure was set at factory requirements, and also set my F1 2010 game to run in DX9 rather than DX11 as this kept freezing on me. Still trying to work through that one.

    Anyway, upshot now people is the bug has disappeared completely, and the BSOD has also not surfaced. Have tested the system quite extensively and cannot make it crash now (unless I run in DX11 mode for F1 2010). So all good.

    First time in my "limited" computing history that I had bad RAM. So perhaps this may help you as well.