• Goodbye Dan Gurney, and thanks for the memories...
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Follow RaceDepartment also on Twitter, Facebook, Instagram, Twitch, Steam and / or YouTube.

General Exporting Wheels?

Discussion in 'Assetto Corsa Modding Discussions' started by Sebmeister, Dec 1, 2017.

  1. Sebmeister

    Sebmeister

    Messages:
    4
    Ratings:
    +0
    Hey, i've tried to get this to work for a good week or so now, but i am completely stuck. I am very sorry if this is the wrong place to post this.

    So i've made this rim and tire, uv mapped, ao baked and scaled it.
    help1.png

    I imported a rim that i know worked ingame, then replaced the mesh of the rim i imported with this one. Saved everything made sure everything was named as before then exported it as a fbx 7.4.
    Import the rim into 3dsim and replace the rim of a car that i know work with the one i made, export, save textures, load it in kseditor. Everything looks fine so i export the file from there, then when i try to load the car ingame it won't load the car, obviously indicating that something has gone very very wrong.

    Is there an in depth tutorial on this or some lovely soul out there that can help me with this?
     
  2. AccAkut

    AccAkut

    Messages:
    1,055
    Ratings:
    +1,049
    You've got pretty messed up texture there on the rim due to overlaying meshes, seems like that rim was initially double sided for some reason.

    Never worked with 3DSimed, but I would guess that it won't load due to ini files in the data.acd still linking to meshes you replaced, potentially the brakes.ini (for brake glow), or the blurred_objects.ini for the blurred rims
     
  3. Sebmeister

    Sebmeister

    Messages:
    4
    Ratings:
    +0
    The mesh looks double sided because it's scaled down, it looks double sided because Blender can't cope with it being so small lol. I don't use rim blur so i deleted everything in blurred objects. But the data.acd thing i haven't checked
     
  4. AccAkut

    AccAkut

    Messages:
    1,055
    Ratings:
    +1,049
    I have build a bunch of cars in Blender, and never came across issues like that... your baked texture on the right shows the same artefacts, something is wrong about the rim
     
  5. Sebmeister

    Sebmeister

    Messages:
    4
    Ratings:
    +0
    Try it yourself, make a cube with 2 of the faces very close to eachother, then scale that waaaaaaaay down. It'll start glitching through, atleast it does for me, nothing wrong with the mesh i can assure you. Anyways back on topic,

    i seem to have solved the problem, one of the wheels are ingame currently so i will take a look at what i could have done right or wrong tomorrow
     
  6. Sebmeister

    Sebmeister

    Messages:
    4
    Ratings:
    +0
    I got it all under control now, thanks for the help