1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Export error (this one is new to me)

Discussion in 'Bob's Track Builder' started by Alex Kyriak, Aug 14, 2011.

  1. I am exporting a track I have been working on for a while (previously with no issues). I get this dialogue box message after an unusually long export:

    Can't export Object reference not set to an instance of an object.

    It doesn't crash, it just puts this message up in the dialogue box, with an OK button. Exports used to be fairly quick. It still seems to have created the track folder in the RFactor Locations folder (although I haven't tried to run it). Any ideas anyone?

    Cheers :)
     
  2. EDIT - might be a SOBJECT / track length problem.

    Think this might have something to do with an operation I have done on the track. I have created an additonal track within my existing track project (an extended loop from the main circuit).

    I rescaled this new track by length, making sure I had Active Track only, by using Resize Exactly, and made sure also to unclick Affect Terrain, Walls, Objects, Background images, etc. But for some reason all the SObjects in the project get repositioned after the track has been Resized. The error only occurs after resizing. So,

    a) how do I stop SObjects being affected from Resizing?

    b)Can a sobject being too far away from the origin cause export errors?

    Thanks all.
     
  3. A: Any track resize will affect every SObject, AIW and CAMs regardless of Active track only ticked. I noticed this one too as someone suggested to use resized track to create AIW to get less waypoints.. Huge bug but i never use resize anyway after draft phase. Unless you want to do the whole thing all over again.

    B: possibly, someone surely knows the exact answer to this.. Anyway the more distance from 0,0,0 you go, the chance of failure increases..
     
  4. Hmmm. not impressed with this bug. The only saves I have of the addon circuit are from after I did the Resize Track, and because I had the SObjects turned off, I didn't see that this happened until too late. So now I can either keep my Sobjects or my new circuit... but not both... :damnit:
     
  5. Does that mean you also have a save from before you created the addon? I.e. with the SObjects intact?

    If that's the case, I think I know what you could do.
    First, make backups of everything.
    From the track with the addon section, remove all the SObjects.
    Go to the driveline tool, and clear all if necessary, then append just the addon section.
    Spend some time tweaking the centreline so that it's as accurate as possible.
    Export the track to rFactor.

    Import the .scn file into 3dsimed.
    Go to the Export menu and one of the options is 'XYZ Data'
    This looks at your AIW file, using it to generate coordinates and build a .csv file.

    In BTB, load your original venue, before the addon was added on, and go to Import, and select the .csv
     
  6. Yes I do have the saves before the addon. I always save a new file every 1 hr of working (a habit I picked up when I first started BTB).

    Thanks alot Soul for the workaround :) I'll have to get hold of 3dSimed and give it a go. I think I ran a demo of it once years ago before I discovered BTB.