• "Boogity, boogity boogity! Let's go racing boys!" - Darrell Waltrip
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Discuss the 2017 Formula One Australian Grand Prix here.

ETS2 steam and soft th dual monitor setup

Discussion in 'Euro Truck Simulator 2' started by Diego Balzarini, Sep 5, 2016.

  1. I looked everywhere and didn't find a solution

    I want to run ETS2 on 2 monitors with soft th but I can't.

    I run win 7, nvidia 750 TI, 2 monitor lg22" connected to hdmi and dvi.

    I get the 2 monitors working in AMS and rfactor 2 but ETS2 renders only 1 monitor resolution leaving the second monitor black.

    I tried both Fullscreen and window mode with no success.
    I tried to use the same config file use for the other 2 sims and created a new one and still no luck.

    I have no idea why it doesn't work leaving 1 monitor blank ( the power light is on)

    I hope someone here has the answer
     
  2. Papy_Yosh

    Papy_Yosh
    Premium


    Ok, try that.
    go to your NVidia settings (right click on your desktop and select NVidia control panel)
    choose "configure surround".
    click "span display"
    click "configure"
    be sure your 2 screens are selected and put them in the right order.
    save settings you should be up and running. open ETS2 go to settings click full screen and review them you should have it on both screen.
    I hope that helps
     
  3. Thanks, I'll try when i go back home after the holidays.
     
  4. Papy_Yosh

    Papy_Yosh
    Premium

    Diego, Any feedback did you get it fixed?
     
  5. Hi, Got back home yesterday, I don't have the option "Configure surround" in the nvidia control panel.
    I managed to get it working though, I'm not sure why is working but it does.
    It works in 32 bit not in 64.
    It starts only on one screen and once i configure video in game the resoultion is already selected and I change the scaling the 2nd monitor start to work.
    This has to be done everytime i start the game. I wonder why but it's working now, may be one of the updates made it work.

    Thanks for your help
     
  6. Papy_Yosh

    Papy_Yosh
    Premium

    I'm glad you found a way around to make it work.
    Just by curiosity, what video card do you have? And what drivers?
    I'm surprised you do not have that option.
     
  7. Nvidia gtx 750 Ti from msi and i have the latest drivers
     
  8. Papy_Yosh

    Papy_Yosh
    Premium

    Hum that's funny. I had the 770 Ti and I had that option. Inside Nvidia settings, on the left side the 3rd or 4th option. Ooh well you have it running that is what counts.
    Enjoy
     
    • Like Like x 1