1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. #GiveAwayFriday. Win a copy of F1 2017 - The Game. Click here to join.

Errors and Crashes on Launch

Discussion in 'rFactor 2' started by schlitty, Jan 2, 2017.

  1. schlitty

    schlitty

    Messages:
    120
    Ratings:
    +91
    Picked up rFactor 2 right before the Winter Sale ended... Won't run.

    Launches, auto subscribes to the workshop items, downloads and syncs those. Then when I click "singleplayer" I get an error dialog window with "Error creating default shader". And after clicking okay on that I get "Error setting video mode". And finally after clicking okay on that, the program stops responding.

    I tried to do some searching about the web but there's never a concrete solution I could find or threads with no followups or people that it just magically fixed. I've tried all the various suggestions I could find though.

    Verified cache integrity on Steam.
    Deleted and redownloaded/installed.
    Deleted user config, player, and shader files.
    Tried various AA, sync, windowed/borderless/fullscreen, settings.
    Tried 32bit.
    Running the exe as administrator in Windows.

    None worked.

    Any help would be appreciated.Thanks.
     
  2. schlitty

    schlitty

    Messages:
    120
    Ratings:
    +91
    For what its worth my problem seems to have been with some permission setting along the way AND my install directory. I have my Steam games installed on a secondary HDD. And for whatever reason rFactor 2 did not like the naming of the directory. I contacted rF2 support directly and that was the last idea to try. I made a second Steam directory just named "test" on my secondary HDD and the game ran fine there. Then I tried in on my primary again (had tried that earlier before fiddling with permissions and stuff) and it now worked on C:\ as well. But still wouldn't fire up in that original directory where my other games are on my secondary. So I dunno. Game works now though! I hope nobody else runs into the same problem but consider changing your directory if you do.

    According to support; "Error creating default shader" is caused by limited space (HD, page file, memory) or permissions or path being too long.
     
  3. Gijs van Elderen

    Gijs van Elderen
    Premium

    Messages:
    4,571
    Ratings:
    +2,357
    rF2 doesn't like some caracters in file names, folder names, usernames etc...
    Charcters like: æ å à œvø ä ę ã õ ō.
    In some countries these characters are used in names.

    It might not the cause of your problem. But worth to check. ;)
     
    • Like Like x 1
  4. schlitty

    schlitty

    Messages:
    120
    Ratings:
    +91
    Definitely worth mentioning for anybody else that finds this when searching. Don't quite know why it didn't like mine. Mine was just D:\Installed Games\Steam\*regular Steam folder structure*

    But I'm crashing cars now, so problem solved! :D
     
    • Like Like x 2