1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error with rFactor loading textures already used in another track

Discussion in 'Bob's Track Builder' started by senna4ever, Mar 3, 2011.

  1. I'm building a track for which I need a couple of buildings. I've been trying to use a couple of buildings that I already used for another track, but now when rFactor tries to load the track it gives me a loading texture error. Although in the previous track they worked perfectly fine.

    Any idea why this is happening?
  2. This could be one of two things off the top of my head. A) they are not the correct size - if they are DDS they must be sized to the power of 2. or B) the textures are not in the correct folder for rFactor to pick them up.
  3. To be 100% honest, these are 3d buildings pulled from Google Earth, the textures are jpeg and very probably incorrectly sized. What is weird is that they worked fine in another track and now they don't in this one.

    If I were to convert them to *.dds, Should I do it after modifying the models in SketchUp, or before? after putting them on the track in BTB or before?
    What would be the best way?
    Much thanks for the replies
  4. If they are jpeg they shouldn't be a problem. What exact error do you get?
  5. i.e. "Error loading texture texture04.jpeg", right after that "Error loading material roada1234", I click OK and rFactor closes.
  6. Kyle Puttifer

    Kyle Puttifer
    @ Simberia @Simberia

    Badly sized jpgs also give problems. All badly sized textures have problems.
  7. Thank you.
    Should I convert the textures before loading them into the Xpack, or before modifying the models on SketchUp?

    The weirdest thing is that these same models already worked on rFactor before, just on another track, which still works fine.
  8. I always find (if the textures are the correct size and/or worked before) that that error is due to the files not being in the correct folder.
  9. Sorry for the noob question but, how do I know if the files are in the correct folder??? I export from BTB to rFactor, wouldn't that do it the right way?
  10. Kyle Puttifer

    Kyle Puttifer
    @ Simberia @Simberia

    Yes, it would.
  11. I will try to batch convert all textures to have it's longer side no bigger than 724. Will keep u posted. Thanx
  12. Hopefully i can get to try this over the course of this next week.
    The track itself is pretty much finished, race surface, kerbs, walls, pits, trees, traffic lights, street lights. but the thing is that it's a city track, so i need all those buildings to fill all the blocks and make it look like a city!! :)
  13. Just tried this, didn't work :-(
  14. Well, I'm moving and my studio computer has to go to a storage place now, so who knows when I'll be able to finish this track :-(
  15. Don't think that's the case, because I just had to readjust some smaller jpgs to powers of 2 sizes to prevent CTD's when loading a track. Once size-adjusted, loaded ok.

    Was the result of some such textures in Jimlaads 'Assorted Track Objects' Xpack, btw (I used a bridge which was in there).