• “Just being a mediocre driver has never been my ambition. That's not my style” ― Michael Schumacher
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

error gmotor with a dds file

Discussion in 'Bob's Track Builder' started by bilbo, May 6, 2010.

  1. bilbo

    bilbo

    Messages:
    16
    Ratings:
    +0
    hello
    i have a texture problem with btb.
    I create a texture with transparency with photoshop (with a alpha layer) ,I save this texture in dds (i tested several type: dxt1, 3, 5).
    with btb, not of problem, I can apply my texture and see the transparency, but when I run rfactor, the track does not loading: error gmotor with my dds.


    thx .
     
  2. chub_pearson

    chub_pearson

    Messages:
    312
    Ratings:
    +2
    What are the dimensions of your image? Both sides should be to the power of two, that is 8, 16, 32, 64, 128, 256, 512, 1024, 2048, 4096 pixels otherwise rFactor will reject it. 128 x 512 is fine for example, but 100 x 500 won't work.
     
  3. bilbo

    bilbo

    Messages:
    16
    Ratings:
    +0
    256*256
     
  4. bilbo

    bilbo

    Messages:
    16
    Ratings:
    +0
    to create my dds file i use nvidia dds plugin for photoshop .
    what's the best setting ? (nvidia dds format v8.23 ) dxt (1 ,3 , 5 ...) , mip map generation ? .....

    what's good profile ....i think this is the problem.
     
  5. martinez

    martinez

    Messages:
    745
    Ratings:
    +14
    I use the same - strange thing was at the beginning - I saved some diffuse textures - ok, then went to bump... Since I did this every next diffuse texture was terribly blured with any setting. Solution for this was only reinstalling the plugin. Right after that I saved first (default) profile and now it's fine, wchich means after saving Normal Map (bump, spec etc.) I have to load saved profile... :)
    DTX 1 does not support transparency, DTX 3 gives explicit alpha, DTX 5 - interpolated alpha. There were great explanations on the Forum not long time ago - please refer to threads:
    "Texture blurring DDS" (on page two) http://www.racedepartment.com/bobs-track-builder/32839-texture-blurring-dds.html - thanks to jharro again!
    "Problem with bump, specular etc" (page 3) http://www.racedepartment.com/bobs-track-builder/32621-problem-bump-specular-etc.html - that was me, luckily the problem doesn't happen anymore, I don't even know why it was like that. There is a link to great tutorial by Eric Tozer - http://www.racedepartment.com/downlo...do=file&id=963

    I don't know if these links work.

    So, if I don't need transparency it's always dtx 1 - you get smaller files.
    And then for some trees I use dtx 3 or dtx 5 (bigger files, but with transparency)
    Also, the number of mip maps is sometime important if you think of file sizes. Sometime it's unnesesary to save all mip maps. I usually save 5-6 for diffuse textures and 2-3 for bump and specular. Then I never have set MIP setting in Xpack over -4...
    Then if I want to have one texture disapearing in another (e.g walls on roads) it always has to be dtx 5, since there some transparent gradient must appear.
    Settings for the plugin - I just play with buttons and always watch preview before saving. Usually give "soft sharpen". Anyway, I recommend the tutorial by Eric - he knows things much better :)

    Before NVidia plugin I used DDS Converter 2 - it has less options, but very easy to - maybe you can try to save your textures with this and check what happens.
     
  6. liquido

    liquido

    Messages:
    160
    Ratings:
    +33
  7. bilbo

    bilbo

    Messages:
    16
    Ratings:
    +0
    thx men !
    it's ok !
    just change mip maps in nvidia dds plugin : defaut (15 ..or 16 ) , it's ok with 6 .
    thx for help
     
  8. martinez

    martinez

    Messages:
    745
    Ratings:
    +14
    Great! I never needed more than 4 (MIP setting -4), so I save usually max 6 mip maps.