1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

End of my rope with this game...the noose is tightening!!!!

Discussion in 'F1 2011 - The Game' started by LeeRex, May 18, 2012.

  1. LeeRex

    LeeRex
    Premium Member

    Alienware computer with Fanatec wheel...all drivers up-to-date. Installed setups from RaceDepartment website. Should work perfectly, but doesn't!!!!

    All cars are very slow, maxing out at 120 mph...no assists!
    Slow acceleration
    Game doesn't always save my settings nor recognize my wheel.
    when the wheel and pedals do work, it seems that the accelerator
    is stuck. only the brake will slow it down. lift off the brake
    and it accelerates again with no help from me.


    questions:
    is the dvd version better, worse or the same?

    is the Fanatec wheel TRULY recognized? a patch maybe?

    where do I set the button functions for my wheel. I want to use the paddle shifters. How?


    Help Appreciated!
     
  2. Sounds like you have combined pedals selected (brake and throttle on one axis). Don't own a Fanatec wheel, so can't help further, but try to find that option in the Fanatec software somewhere.
     
  3. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    I think Senad is probably correct. I don't own a Fanatec wheel either and can only make suggestions like :-

    1/ Download and install the latest software for the wheel, assuming there is configuration software.

    2/ Ensure you are using a USB2 and not a USB3 port (if you have them). I have read some mention of this for some Fanatec users

    3/ Start the game with your keyboard enter key rather than the wheel, then once the game is running select your wheel again as controller or setup a custom wheel. This should reload the actionmap for your wheel.

    I mention number 3, because only a few days ago with my Logitech G27 online, I had a similar problem. Slow acceleration, top speed 150 MPH (others were doing 200 MPH). Rebooting the game and starting a new MP session did not help, nor did rebooting my Logitech software (profiler). It only started working correctly after I booted the game via the keyboard, and re-selected my G27 wheel. It was the first time this had happened, I guess something got corrupted somewhere.

    Good luck
     
  4. LeeRex

    LeeRex
    Premium Member

    Thanks to you and Senad!...Here's a bit of history. F1 2010..really looked forward to it but found the game very quirky and even unplayable (poor frame rates and lots of crashes)...finally realized that my old computer simply wasn't up to it....Soooo I bought my Alienware,Fanatec wheel and F1 2011...cost a damn fortune! So imagine my frustration when even these upgrades didn't fix much. So much for my whining.....
    Answers:
    1) Software is up-to-date. I DL'd the game from Steam and, supposedly, it updates automatically.
    2) Never heard of usb3. What's the difference?
    3) I've read the manual front-to-back and there is no mention of ways to start the game...
    another quirk?...but I always start with the keyboard.

    Simply put....the game is not straight forward nor simple to understand...I feel forced into "career mode"...changes I want to make are difficult to find...it takes forever to load....and all the other problems I've already mentioned.

    Sign me "frustrated".....Lee
     
  5. Andrew Bortz

    Andrew Bortz
    GoldenBortz

    Yup agree with Senad it was the first thing I thought of, I don't have a fanatec but in my Logitech profiler theres a tickbox for combined pedal which if im not mistaken will only give you 50% throttle and also 50% brake.

    If you can't find it then possibly try setting the sensitivity to 200% if thats even possible.
     
  6. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    I am still with Senad (and Andrew) on this one, referring to the combined pedals thing. You don't mention which Fanatec wheel you are using, nor which pedals you are using. I am under the impression that not all Fanatec come with pedals, but I could be wrong, as I have never owned any of their products.

    @ Andrew: The throttle sensitivity within the game can only be set to 95 max.

    USB 3 is the latest and fastest USB port. Most people have USB 1.1 and 2.0 ports, but newer systems can come with USB 3.0. If you are not aware of USB 3, then I suspect you system probably doesn't have them. It may be worth checking your PC Manual or Motherboard Manual. I have seen mention of some Fanatec users having problem that were solved by plugging the wheel into a USB 2 port (they had them plugged into USB 3 ports).

    Regarding software. Steam, updates your game (F1 2011), not any driver or profiling software for your wheel/pedals (AFAIK).

    I am assuming that Fanatec are just like any other wheel manufacturer, in that they use their own software to provide more functions and setup choice for their products, usually 'profiling' software which is used to setup the wheel/pedals for different games, and assign commands/functions/macros to wheel buttons. This is over and above standard Windows drivers, which simply allow your hardware to be used on your system.

    The slow acceleration, and the fact that you are accelerating when you lift off the brake, sounds, as Senad pointed out, like your pedals are programmed to act as if the brake and accelerator are combined on the same axis, when they each should have their own separate axis.

    This software is usually on any CD/DVD that comes with the wheel, or available at the manufacturer's website in their download section.

    For instance I used a Logitech G27 wheel/pedals. It will work with all my games, and Windows recognises it as a controller. However for more control of the wheel and for setting up the wheel to how I like it for each driving game that I have, I download and installed Logitech's profiling software. There a picture below of some of my settings, and I have circled in red the function that we think you need to change. I would be suprised if Fanatec do not have similar software which you can use.

    [​IMG]
     
    • Like Like x 1
  7. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    BTW, when you say that you are not aware of different ways to start your game, I mean this :-

    1/ If your wheel is correctly found by the game, when you run the game there is a START button that is used on the wheel, and you asked to press it during the game boot. If you don't know the button, try them all ... :) By pressing this START button, you wheel is selected as your controller automatically.

    2/ If when you are asked to press the start button, but you use the ENTER key on you keyboard, you have now selected the keyboard are your device to control the interface AND as your steering device.

    3/ A common way of fixing wheel problems OR if you are one of those guys who edit the actionmap file for your wheel directly (like me), is to start the game with the keyboard ENTER key, and once you are in the game re-select your wheel. This forces the game to read that actionmap file again, either because you edited it, or because the game's stored settings have become corrupted.

    As to the pedals:-

    I suppose another way of checking your pedal settings, or perhaps fixing an incorrect setting, is going into the game and customising your pedal settings. After selecting your wheel, go into the settings, and see what axis has been assigned to your throttle and brake. If the settings show that they are both on the same axis, it COULD be the wrong setting for the pedals (incorrectly sensed).

    Double check your settings by editing them. Select the throttle, hit your keyboard enter key, and then press your throttle pedal. This will assign an axis to your throttle. Is it the same as it was before?

    Now do the same for your brake pedal, is that the same as before?

    Probably more importantly do both the throttle and the brake get assigned the same axis? (usually positive and negative values on the same axis). Or does the throttle and brake show as being on a different axis? If so, you may just have fixed it.

    Example picture of my G27 :-

    The first one show the assignments when I use the normal throttle and brake pedals in the game. You can see that they are on different axis. (Y and RZ)

    [​IMG]

    In this second picture I show MY current setting, because I don't use the normal brake pedal, I have assigned my clutch pedal as the brake (for left foot braking). Again they are clearly on different axis. (Y and Axisslider1)

    [​IMG]

    If by re-assigning the throttle and brake pedals within the game fixes it for you, then great. If it doesn't, then this is where you probably need that profiling software (mentioned previously) for your wheel, so that you can change the red circled setting shown in the image in my previous post. (Combined pedals is de-selected)
     
  8. LeeRex

    LeeRex
    Premium Member

    ALL OF YOU ARE CORRECT AND MY THANKS GOES OUT TO YOU! The pedals were on the same axis as Senad suggested and all agreed..fixed it. I also have a much better understanding of the menu system though I still think it's a bit clunky. With these changes, the game is working well and my frustration is relieved. After a little practice I should see you guys at the track sometime soon! Thanks again!
     
    • Like Like x 1
  9. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    It's good to know that it's working for you now. :)

    Can you confirm what fixed it?

    Was it in-game, assigning the brake and throttle axis?

    Or is there profiling software available that you used to change the combined pedal option?

    It might help someone else with a Fanatec with their problem, if they know what you did.

    Cheers
     
  10. LeeRex

    LeeRex
    Premium Member

    It was the in-game axis. Just followed Senad's suggestion (above)..Your screens were very helpful...software for the Fanatec wheel is on the wheel itself (a small digital screen just above the hub that you can set on the fly)
     
  11. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Excellent, thanks :)